Critical Error E1 when trying to do anything

I'm not sure if I received a lemon or not. But upon unboxing and powering it up for the first time, it brought me straight to the settings menu instead of the first-time boot experience.
And if I try to do anything (open any setting or connect it to wifi), the device crashes error e1 and restarts. But it's just stuck in a loop.
Also when I press more information I am left with this:

I think it's recommended to contact Playdate support at

Yeah, I figured. I believe it's a corrupted OS, hopefully not hardware related.
I'll have to wait for support then.

Would you happen to know if it's possible to flash a fresh install of the playdate OS onto the system using my pc?

It is, but only with the assistance of official support staff.

First try a paperclip reset for 10 seconds (the reset button is in the crank slot). If that doesn't work, try installing the recovery firmware, steps are listed here: Recovery Mode - Playdate Help

Thanks for the link to the recovery page!

Sadly after attempting the steps it listed, it still doesn't seem to fix it.

The Recovery steps seem to be for when you have a E2 level crash. It seems I have a very very rare E1 crash. I believe my only options now are to wait for a flash image from support or the device may just be a defective one.

Still no update from support yet. I know they are backed up with tickets from the latest shipment wave too.

Does anyone happen to have a link or recovery image for the playdate they could share with me?

I am currently using d0114b2d74cd-2.0.0-release.155213-buildbot

I am able to connect to the playdate sdk and access its BOOT segment. I think if I had a fresh recovery image, I could get it working.

I just want to use my playdate already ;(

Support has to generate that image, they should be contacting you shortly.


I believe I am having the same issue. Do you happen to have a recovery image you can share to get mine up and running?

They did give a firmware image, but from what they say, they are all generated specifically for each playdates serial number so you can't share them.

Even with the fresh firmware flash, it did not fix the issue. I believe it's a hardware defect and needs to be RMA'd.
But I haven't heard back from support since they gave me the image last Thursday which is a little worrying.

1 Like

It's now been 7 days since I've last received anything from support. My playdate is still bricked. Not sure what to do now...