Error loading game .pdx from another drive

I have my game (.pdx folder) on a different drive than Playdate SDK, when I try to open it either by dragging on the simulator or Ctrl+O I get "Load failed:" with no message.

I tried loading it from SDK\Disk\Games and I got "Load failed: Games".

FInally I tried to load just from the root of the same drive where SDK lives. And I got a proper message about my EventHandler not being properly exported.

When I fixed the issue with EventHandler I succesfully loaded it from SDK drive but when I try to load it from another drive I still get "Load failed:"

1 Like

Thanks for the report, this will be fixed in the next release.

Hi, I've been having the same problem. After updating to the newest SDK (1.9.2), the problem persists but the error message has changed:

19:07:27: Loading: Failed
update failed: "(null)" was built with an old version of the SDK.

The device firmware has introduced an incompatible change since this PDX file was compiled.

PDX version: 0
Firmware is compatible with 10000 and up.

Please update and try again. Thanks!
19:07:27: Update failed, simulator paused.

(The same PDX loads fine after moving it to the same drive as the SDK)

The fix for this issue hasn't made it into the SDK just yet. The next feature release will contain it, thanks for keeping tabs on it. :slight_smile:

Hi, even after updating to latest version(1.9.3) I am still having the same problem.