Installation of SDK/simulator failed

My Playdate arrived yesterday (very nice :grinning:).

However, the installation of PlaydateSDK 0.10.2 failed (please see attached screenshot).

I’m trying to install on a MacBook Air, with macOS 10.15.6 and 25.74 GB storage free.

Tried redownloading and reinstalling, but no luck.

Screen Shot 2020-07-25 at 8.13.23 pm

Hi, I suspect that there is a permission problem that this version of the installer can’t handle. Please open Terminal and run the following

sudo chown "${USER}": ~/Developer

It’ll ask for your password. After that try running the installer again and let me know how it goes.

Hi James. No luck - installer still fails with the same message.

Would it help to have the installer log? (I tried uploading it, but the forum doesn’t accept PDFs)

Sure, if you could mail me /var/log/install.log that might be helpful. Thanks!

I’m also getting the same error when trying to install the SDK on a MacBook Pro, running Catalina (10.15.6). Is there a workaround, if I may ask?

Send it to james@panic.com please.

I have one from my new computer migration that I’ll send now.

@matt @rokashi the installer failed when trying to detect if you had xcode installed so the SDK itself is fully installed. If you install Xcode from the App store you’ll be set.

The problem that caused the installer to fail is fixed in the next release.

1 Like

Thanks, it worked for me!