Problem building with Windows

So, I have the exact same files on two computers, my Windows machine and my Mac. Building on my Mac works fine, but building it on Windows just doesn’t start the game and keeps the “PLAYDATE DEVELOPER PREVIEW” message on the top. This is the code I’m running:

pdc -sdkpath "D:/Other Things/Tools/Playdate SDK/CoreLibs" source build.pdx

No errors appear in console, yet it won’t start.
Any ideas?

The only thing that looks iffy is I think the sdkpath shouldn’t include CoreLibs. But I’d expect the compiler to throw an error if that were actually a problem.

If you zip up both build.pdx builds from the two platforms I can take a look inside, see what the difference is.

Oh yeah, I forgot to mention - the “CoreLibs” part shouldn’t have been there, I tried to mess with it and that didn’t load it properly. Will send over copies in a sec.

test.zip (13.1 KB) I think this is how you upload files.

Update: the build isn’t the problem! Somehow it seems to be the launcher. Nevermind. Got too excited.
I think the problem is actually how I’m installing the game. pdutil doesn’t play nice with me for me and crashes. I’ve been installing manually but that’s probably the issue. Here’s the output:

D:\Other Things\Code\Lua\Playdate\test>pdutil install build.pdx
Playdate device detected on COM5
Installing "build.pdx"...
Waiting for drive to appear...

Unhandled Exception: System.IO.IOException: The device is not ready.

   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.__Error.WinIODriveError(String driveName, Int32 errorCode)
   at System.IO.DriveInfo.get_VolumeLabel()
   at pdutil.Playdate.FindPlaydateDrive(String labelToFind, Boolean wait)
   at pdutil.Playdate.MountDataDisk(String comPortName)
   at pdutil.Playdate.Install(String comPortName, String pdxPath)
   at pdutil.Program.Main(String[] args)

This sounds like a Windows tool issue, so I’m going to tag @stevenf.

1 Like

I’ll take a look at this today. It’s trying to read the drive labels of all the drives on your system, looking for “PLAYDATE”, and hitting something it doesn’t like along the way. “Device not ready” makes me think possibly a floppy or CD-ROM drive with nothing in it? Probably just a matter of catching and ignoring this exception. I’ll post an updated version to try later.

Sounds like what’s happening. My disk drive has nothing in it and it usually trips up a lot.

pdutil.exe.zip (4.8 KB)

This version should silently skip over the inaccessible drive. Could you give it a try and let me know how it goes?

1 Like

That worked! Thank you so much!

Great, we’ll get that rolled into the next SDK release!

1 Like

This fixed the exception issue for me as well. Thanks!