Simulator just won't start on Windows

I've tried every Playdate SDK since the original release and the simulator still doesn't work for me. The window just opens with a frame and blank contents, and then closes a few seconds later. No error messages or anything.

Event Viewer just shows the following

Faulting application name: PlaydateSimulator.exe, version:, time stamp: 0x62351ba5
Faulting module name: PlaydateSimulator.exe, version:, time stamp: 0x62351ba5
Exception code: 0xc000041d
Fault offset: 0x000000000000d2a2
Faulting process ID: 0x8a4
Faulting application start time: 0x01d8486aee1a87a7
Faulting application path: C:\Users\[me]\Documents\PlaydateSDK\bin\PlaydateSimulator.exe
Faulting module path: C:\Users\[me]\Documents\PlaydateSDK\bin\PlaydateSimulator.exe
Report ID: a2c9e033-9f63-4901-9e3a-c62d978a016b
Faulting package full name: 
Faulting package-relative application ID: 

So that's exception code 0xc000041d which is apparently "An unhandled exception was encountered during a user callback." according to what I can find on Google.

Seems like a bug in the simulator. Hopefully there's enough info here for you to fix it.

How are you opening it? Are you just double clicking the executable or trying to run it from commandline?

Also what version of Windows are you using?

Have you installed the C++ redistributable runtime listed the README? If not, please try that and report back.

I already have that installed, also it seems weird that there's no mention of that on the SDK documentation site and is instead in a README file that I didn't even know was there!

I just installed the latest version though, 1.10.0 and it now works. So all is good.