Task “Playdate Simulator” encountered an uncaught signal

Something really bizarre started to happen to me recently. Every time I try to load up a new Gif file as an image table, when I compile, I get the following message from Nova:

Task “Playdate Simulator” encountered an uncaught signal.

Here's what even stranger: if then I remove the code to load the gif file altogether, I STILL can't compile. I can even revert to a former code that doesn't even mention at all the gif file, I will keep getting the error message.

But that gets even more bizarre. The only way I then have to successfully build is to delete the gif file from the directory in which the project is located. As long as this file is in there, no code will compile, even a 5 lines code, regardless of the fact that the file is even mentioned in the code.
But the weird doesn't stop there. If I move the gif file to a different location, open it in Photoshop, and then save it back INTO the project folder, that exact same gif file will now load and the code will build without problem.

Boy this one is a head scratcher. I must be doing something wrong but for the life of me I can't diagnose the problem or make sense of it.
It's worth noting that I both tried Nova 8.3 beta and 8.4 and still get the same problem.

If someone has encountered this I'd love to know their take on this.

Any file will be included in the build if it's in the Source directory. Image, PSD, zip, whatever. This explains part of what you're seeing. Everything except your last point.

So, it seems like there's something odd with your first GIF and you should send a problem image (and the later working image saved from Photoshop) to @dave

Q: are the bad and good GIF files byte-for-byte identical? I suspect not and this is the key to figuring the problem.

Yep, sounds like it should :crossed_fingers: be easy to reproduce given the weird file.

@StephanRewind If you can DM that to me (or just post it here) it'd be a huge help. Thanks! Also, it sounds like the error is actually in the compiler but Nova makes it sound like it's in the simulator. I'll check that and file it as a separate issue.

Thanks a lot, guys. Maybe somehow when I saved back the file as a gif Photoshop didn’t exactly recreated the gif identically? I also noticed in the past that some gif files exported from Aseprite seemed ok when played in a browser or imported in Photoshop, but had some corrupted frames once turned into image tables. I never had any issues with image tables out of a sequence of png images, so there’s definitely something related to the gif files themselves.

Next time I get this error I’ll send you the gif file, so you can maybe figure what’s wrong with them.

Stay tuned. I’m sure it won’t be long before I get another one.

Thanks again.

1 Like