Update Error: could not load the Library (SDK 2 beta 2)

Hey all - I'm at a bit of an impasse, because I'm trying to load a new SDK 2 friendly build of our game SKEW in the latest Playdate Simulator beta but I'm getting the following error:

This is only happening on my two Windows 11 machines. I have turned off malware and virus protections. Deleting the game from the Disk/Games folder and then putting it back in there allows me to at least see the game listed, but soon as I launch it, I get the error again.

Anyone have any ideas on what may be causing this? It does feel like some sort of absurd Windows permissions thing. Thank you.

1 Like

Sorry you're having troubles. I tried the build of Skew here yesterday and it worked for me which is very odd. :slight_smile:

  1. If you rebuild using the 1.13.x SDK it works on these machines?
  2. error 126 is ERROR_MOD_NOT_FOUND which seems like it's a dependency issue; did you weak link a library that isn't available?

Oh also, how are you building this? What build system are you using?