Battery charges slowly

Hi! Just received my playdate and it appears to be charging extremely slowly -- in about the last hour, it's gone from 83% to 84%.
In addition, the battery's charge maxes out at 85% and unplugging it for just a few minutes causes a dramatic drop.
I'm on firmware 2.0.0. I've tried various fixes including resetting the device and turning off the automatic clock sync, but nothing seems to help.

I would greatly appreciate any help that can be provided.


1 Like

Hi John, this is a bug that we're aware of and hope to have a fix for soon. There's nothing wrong with your device - it's just a software bug.


I’m also having this issue, and the clock skew is shockingly bad - my playdate is losing over two hours a day

(this was after syncing the time at about 09:00 this morning)

I’ve only had it two days, and I’m finding the experience really disappointing - arriving with a dead battery and no indication it’s actually charging when plugged in, slow/not charging (it’s never gone above 83% even after charging all night on a 2.1A charger), and constantly crashing.

Is all this expected? I would’ve thought waiting two years after ordering (two years and a day to be exact) would be more than enough time to iron out the kinks.

No, that definitely doesn't sound normal or expected! For the battery OR the clock. Hope you get it all sorted out soon!

1 Like

Just for an update on this, here’s what it looks like this morning. More than 1.5h slow after 24h! I was keen to buy the planner, but it’s not going to be very useful it time is so poorly handled.

A minute or so drift per day, rarely exceeding 2 minutes total because it corrects itself off the network (if connected)—has been the norm for me.

(I made the Playtime clocks collection, which wouldn't be much use otherwise!)

Might be worth contacting Support to see if you need a swap. Hopefully it's a software fix though!

1 Like

@james could we not marked this as "solved" until an update is provided? I'm extremely frustrated. I unplugged my device for a moments and now it's stuck at 75%.

The charge value bug is being investigated right now. We should have a fix out for it in either 2.0.2 or 2.1.

I'm sorry this is happening to you. We're getting several reports of the issue and we're investigating it now.

Just wanted to say my new play date is exhibiting this same behavior. Very quickly “charges” to 85% and tops out there. Doesn’t seem to charge past 85% no matter how long it is left charging. Hoping for a fix soon.

My play date also doesn’t seem to charge properly only charging up to 89 percent each time???? Pls fix

Please update to 2.0.3 and see if the battery indicator goes up to 100%. Let us know if you continue to have troubles.

Same here. Mine is up to date. Won’t charge past 84%.

Unfortunately same here. Mine arrived this weekend and won't charge past 83%. I'm running version 2.0.3.

I have the same problem, running v2.0.3. But managed to get it to 100%. I have a cable that displays the wattage being used when charging devices, so here's the process I did:

  • connected to wall charger. got all the way to 83% in about 10 minutes using the max output provided by the wall charger

  • At 83% it was stuck for a while. and the cable was showing 1.6 watts for about 20 mins and then it went to 0 W.

  • I unplugged the cable, replugged, no change.

  • Changed from my cable to the original playdate cable, and plugged it to a PC. The battery went immediately from 83% to 90%

  • waited 2 minutes, unplugged and replugged cable, and it immedately went to 100%.

So I think the battery should be getting charged to 100%, and this could be a syncing problem between the battery status and the device, maybe?

1 Like

I'm led to believe that any modern device's battery doesn't really have a fixed, concrete "charge level" but rather a complex set of factors to measure and estimate in software to come up with the oversimplified number we all like to have. And I think the Playdate lacks a dedicated battery measurement chip, making that even more true. (Correct me or add detail if you know more!)

So the software-displayed NUMBER could be a pretty separate issue from the charge itself and resulting play time.

I have one of the early Playdates and I've seen the charge go up or down quickly after plugging/unplugging cables—or even exiting an app to the launcher. Or at least I saw that a year ago... I kind of stopped paying attention!

Maybe the software for estimating that % number just needs more refinement? (Either way, my Playdate lasts a long while so I'm happy!)

1 Like

That's exactly it. In my original prototypes I did have a "coulomb counter" chip but somewhere along the way that got removed and I didn't notice, leaving us with only the battery voltage to guess at what the actual State of Charge might be. And the relationship between voltage and SoC is far from a one-to-one mapping--there are lots of extra variables there like how long it's been charging/discharging, how worn out the battery is, random manufacturing differences.. Even if we did have a function that could tell us a percentage from that info we don't have a way to track it all.

So what we have instead is basic voltage->percent mappings for charging and discharging, then some hackery heuristics so that when you switch between the two the percentage doesn't change wildly--though, as noted above, there are some cases where that isn't doing its job quite right. Added on top of that is the problem we had with some recent boards where the voltage ADC was miscalibrated making it look like the device isn't getting to 100%, though it was actually at max voltage.

If only we had that coulomb counter. :sob:


Same problem with my new playdate. Just got it and I found the battery problem. Slowly charging and maximum capacity 83%.

I hope it’s possible to fix with update…
Don’t want to return my device.

I have this exact same issue. v2.0.3

First few days it only charged to 83% after a very long time. I was able to get it to 100% but then it stayed at 90%. Then only 10% after leaving it on the charger for 24 hours. I tried to restart it and it only displays the dead battery image.

I have same problem with charging. I hope fix will be released soon :pray: