Cannot Register Simulator (404 url)

Hello,

I just installed the SDK (congrats on the public launch!). When running the simulator (Version 1.9.0 (132294)), in the Settings, when I go into "Account", I see a screen saying "Register Simulator // Press A to go to your account ..."

Pressing A opens https://play.date/register-simulator/ in my default desktop browser which is a 404.

Thanks!

Greg

1 Like

That's the correct URL, but you need to be logged in to your Playdate account to see the page properly.

That it shows 404 I agree is a bug.

I also experience the same issue, I am logged in on my account but I get a 404.

When I'm not logged in, I definitely get a sign in page.

But once logged in, that url is 404 for me. (I see that @Ketebece seems to be experiencing the same issue as I am)

Thanks!

It should look like this, screenshot taken just now.

Maybe it's a permissions thing?

Also experiencing the same thing! Page does not exist anymore from what I can tell. Fairly certain I remember it being a thing, but it's no longer in the account menu.

After logging out and in again (I did try that before), I was finally able to see the page.

I don't know whether anything was just fixed or if it was a weird... cookie issue?

But in any case, it works! Thank you!

1 Like

May have been a server-side issue. Just tried again and worked for me as well, after trying several times over the last half hour.

This should be resolved now. Thanks for letting us know!

4 Likes

I can access the page properly now but I get an error every time I try to register the simulator. I tried registering it from the settings menu and the other way around from the website without success.

1 Like

I get the same error, "Unable to register".


I'm still seeing the issue. I've tried Chrome and Firefox, Private windows, closing everything, signing out, etc.

I cant play any games either. is it the same problem?

I'm having the same issue - page works fine, but I get that dialog box when trying to register. Win 10.

I'm experiencing the same registration issue.

I was having the same problem, but was able to work around the issue by creating a file in PlaydateSDK\Disk\System called access_token and manually pasting the token text in that file.

1 Like

I can't get this fix to work. Is it just a basic text file you can make in windows in the \System folder or does it go in a special folder after making it. And does it have any special format on the file like "access_token = accesstoken..." and do I need the PSIM in there as well?

Although it fixed the registration problem, I am having other issues that seem to be related... for example I can't play games.. so I guess it's not really a workable solution. But it is just a file called "access_token" (no extension) in the Disk\System subfolder of the Playdate SDK folder. Using a text editor, I pasted the 38 character token (including the '-'s) that matches my device's PSIM as the only thing in that file. Whatever is wrong seems to be preventing the simulator from creating it when registering.

I see... Well thank you for letting me know :slight_smile:

Thanks everyone for reporting! We're taking a look at it right now and will reply back here when we have an update!

1 Like