Device crashes when refreshing list of games

I recently updated my PD-01 from the stock firmware so it can now get over the air updates. Everything seems to be in good working order save for two weird things:

  1. The device isn’t recognized as being attached to the simulator (despite being registered, unlocked, powered on, and connected to my Mac with the provided cable).

  2. The device reliably crashes when the (empty) list of games is refreshed.

Repro steps for the latter:

  1. Go to Settings.
  2. Go to Games.
  3. Wait several seconds for the “Refreshing List” animation to run in the upper left.
  4. Message “Sorry, your Playdate has crashed, Press A to restart” is displayed.

This happens whether the device is connected over USB or not. The device has otherwise been able to connect to your servers over wifi. Playdate OS 1.4.0, macOS Monterey.

UPDATE: I sent a crash report via the menu option to do so.

Update: it seems the unit is also crashing periodically when just sitting idle on the main menu; I’ve found it in a crashed state a couple of times now with no interactions after “Hitting A to Restart”. Might just be time to factory reset this thing? Let me know.

This one is Monterey. It’s been mentioned by Neven that hopefully Apple will fix it soon.

1 Like

Any ideas what I could do to remedy the crashing situation? I feel like this will be a blocker to loading games onto the unit even once the Monterey issue is cleared up by Apple. It just crashes on its own from various menus with what seems like increasing frequency.

I wonder if this might be related to the battery issue I’ve heard about. My unit did sit on the shelf for several months unused, and it does seem to go from fully charged to out-of-juice quite rapidly… could power issues be causing kernel panics maybe?

I thought the battery issue was only production devices, not the initial developer preview devices?

Did you try a factory reset?

That’s good to know re: the battery issue, I really don’t know much about that. But I will say it feels like the battery life is far shorter than expected when the device is sitting around idling…

Just tried a factory reset (via the device’s settings menu- very smooth process!) but sadly the issue persists— device crashes while waiting for the list of games to populate. But yeah, I doubt this is a battery issue because this is true even when it’s plugged into USB power…

Kind of feels like it’s stuck in a loop doing something it can’t do or shouldn’t be doing.

A few more things to try:

  • poke something in the reset hole in crank slot
  • load on fresh copy of system from SDK folder
  • summon @dave

Thanks for the suggestions! I tried resetting via the crank hole… same issue as before. I can try reloading the system from the SDK folder, though I’m not sure that’s possible if my device isn’t recognized by my Mac running Monterey? Maybe it is time to see if @dave has any suggestions.

What’s your device’s serial number? I’ll see if anything’s shown up at memfault

Thanks! It’s PDU1-Y000225, also FYI I recently un-registered it from my account, in case that matters.

Okay, I see the crash traces at memfault, and Marc commented (3 months ago??) on it pointing to the fix merge request. Has it really been that long since we had an SDK release? :flushed: I guess the battery situation really threw us for a loop there. Hold on just a little while longer and we’ll have the update out. Though… I guess I could put you in the beta cohort if you want to test that out?