Device doesn't boot anymore after system update

I started updating to the last system version on the device, and now the device is stuck on a screen with the playdate logo, while the white light on the lock button is blinking around twice a second. It stayed like this for a few hours now (fully charged and plugged in). I tried resetting it at some point with a paperclip, but it just boots back to this screen and stops there. Any ideas what I could try?

ouch. so sorry about that. :persevere: Can you try forcing the device into disk mode via the reset button? (It’s in that little hole in the crank receptacle. Poke something in there–a paperclip works great–and you should feel a click.) Two clicks should give you the BOOTSY disk where you can copy a firmware image we send you, and the device will flash it when you eject the disk. Three clicks should give you the PLAYDATE disk which has the game data. It also might have errorlog.txt and crashlog.txt files which might help us figure out what happened. The clicking can be a little fussy–sometimes it takes three clicks instead of two, and you have to do it fast enough but not too fast, but we should be able to use that to get things working again for you. What’s your device serial #?

thanks, I was able to start it as BOOTSY/PLAYDATE disk. Everything seems to look the same like before, shouldn’t the update reset all the data? Where can I get the firmware image?

Crashlog.txt looks like this:

--- watchdog reset at 2020/10/12 08:26:28---
   r0:20028708    r1:00000000     r2:00000020    r3: 20028728
  r12:20028768    lr:00000000     pc:080a7642   psr: a1000000
heap allocated: -957950155
Lua totalbytes=1941438205 GCdebt=187545896 GCestimate=607686360 stacksize=-1184244750

looks like an old error message.


wifi/wificonnectprogressview.lua:61: attempt to index a nil value (upvalue 'controller')
stack traceback:
	wifi/wificonnectprogressview.lua:61: in field 'timerEndedCallback'
	CoreLibs/timer.lua:275: in local 'callEndedCallback'
	CoreLibs/timer.lua:310: in upvalue 'updateTimers'
	main.lua:366: in function <main.lua:359>

lua_exec() expected 1 items on stack, but it has 2

I had some problems connecting to wifi right before I installed the update (with working wifi).

It has been some since I last looked at this. Tried it again now, and unsurprisingly I still have the same issue.

@dave could you tell me where I can get the firmware image?

Please message @Arisa about this.

1 Like

Will do that, thanks!