Excessive battery drain (maybe due to automatic time sync?)

First of all, I’d like to be clear that it it strange and I only have some empirical evidence.

I recently noticed that the device was draining the battery excessively quick when on standby. I charged it to 100% and left it locked and after approximately 1 day it had died. I retried the process and I noticed that first it seemed to crash at some point after I left it (because the clock was correct when I disconnected it and after some hours it had a previous hour on the screen and seemed unresponsive). I tried the clip method and it seemed to work at first but that day or the day after there was a software update which I applied.

I retried charging it to 100% and left it and it was the exact same issue it died after less than 1 day on standby.

I went to the settings screen and I disabled the automatic time sync (this was my only idea to try) and I repeated the process and miraculously it seemed to have worked. It’s been a couple of days since I did this and the device has been on standby and the battery seems to be still on 100% (or the icon full) and the clock is correct.

My only suspicion is than on some update something happened to the time sync code or something (maybe the sync frequency or a looped code).

I have no other ideas at the moment of other things to try about this issue other than re-enabling the time sync and seeing if the issue reappears but maybe you have seen something similar or have hardware to measure other things.

I’ll re-enable the sync and update this post with the findings.

1 Like

Well, after approximately 1 day on standby, the battery seems to be almost at 100% so… I guess this issue is solved? I’ll keep an eye on the device in the next few days but it’s looking like the issue is nonexistent right now.

Just to report that the issue appears to be solved. I do not know what happened here but after a couple days it keeps showing the correct time and the battery is still close to 100% so I guess that’s it. I’m marking this as a “solution” so it’s showed as solved.

1 Like

On firmware 1.4.0, mine is crashing on standby with the digital clock and the battery is 100% drained after 1 day.

Tried factory reset and all and still same behavior.
Automatic time sync is ON as well.

Hello again. I have a new theory. I think that the issue is present when a magnet is close to the device. In my case, it was near an iPad smart folio that has some strong magnets.

I’m only speculating but maybe there’s something to do with the announced dock and maybe the device switches off some power saving features when it thinks that it’s attached magnetically to the dock?

Again, it’s just a theory but since I stored the device away from any magnets the issue seems to be resolved.

I've started seeing this on my device this week. I don't think anything has changed, it came shipped with version 1.12.3 and this is what it is still running. I get about a day on standby to go from 100% to completely drained. When I go check on it though, the clock screen shows battery juice but when unlocking it, it shows and empty battery.

Any help would be appreciated.

Cheers

Erik

Here is an update on my battery experience. Last week I got the final update of my season 1 games and after that I've had no issue for a week with the battery draining. Without too much evidence it feels perhaps it could be related or it could just be a coincidence.

Cheers

ERik