"Found duplicate key "version" in pdxinfo" error when sideloading

I just rebuilt my project using the current version of the SDK/tools.
It runs it in the simulator and on my device just fine.
I zipped it up and tried to sideload it through the website and i get the error "Found duplicate key "version" in pdxinfo"

The pdxinfo file has a unique version key, does not have a duplicate of it... so i don't understand this error.

I changed the version and build numbers, rebuilt and re-zipped it, and now it works fine.

The files are available through itch.io:
LlamaCarrot by BleuLlama

the .200.zip file is the one that fails
the .200b.zip file is the one that works.

If it is in fact an issue on my end from like having a problematic build number, then the error notice should be changed. (The previous version had a buildNumber of '102'.)

Just took a look at the downloaded files and your pdxinfo from the 200 version has a git conflict in it:

author=Scott Lawrence - yorgle@gmail.com
description=Find a carrot for a llama
<<<<<<< HEAD
>>>>>>> e3febc854b526d440f2b073f4ba822fc335d9330
1 Like

weird. I SWEAR the one i uploaded was post merge. not sure why that ended up in there.

okay. problem was 100% my stupidity. :smiley:

Need to close the ticket. apologies.