How to make Mirror work on Linux?

Hello ! I'm trying to use Playdate Mirror on my Kubuntu 20.04 laptop but it won't work.

Here are the steps I'm following :

  • I launch the Mirror app.
  • The Mirror Update popup opens, but I'm already on 1.0.0 version and there's no newer version.
  • The Mirror app screen show the "Connect your Playdate" message.
  • I connect my Playdate (screen is locked) to the computer through USB.
  • I unlock the Playdate screen, a small sound is played by the console, but nothing happens on the app.
  • I close and reopen the app, now the app screen shows the "Problem connecting to Playdate" message.

A file is given with the app. I've put it in the most common lib folders and repeated the process, nothing changed. I've also installed the lib through sudo apt install libserialport0, same problem.

And controlling the Playdate Simulator with my Playdate console works perfectly.

Is there any step I've forgotten to follow ?


I'm under the same boat with Arch Linux. Same issues as OP. I ran this under the terminal and this happens:

INFO: Serial thread entry
INFO: Try to connect
ERROR: Failed to find gamecontrollerdb.txt
INFO: MirrorApp: Connection Error: Connect your Playdate
INFO: MirrorApp: Connection Error: Problem connecting to Playdate
INFO: Try to connect

It will then loop

INFO: MirrorApp: Connection Error: Problem connecting to Playdate
INFO: Try to connect

Could this be a USB permission issue or could this be missing a certain dependency?

I'm a Fedora 36 user, and I had the same problem and also read the other thread.

Patching an installed library seemed a bit extreme to me, and I already happened to have the libserialport-0.1.1-13.fc36.x86_64 package installed on my system. Simply deleting the bundled with the Mirror app solved my connection problem.

My user was already a member of the dialout group for serial port access.