Mirror 1.0.0 on ZorinOS Linux: "Problem Connecting To Playdate"

Hi folks. I'm unable to get Playdate Mirror working in Linux. I'm running ZorinOS 16.2. Everything I searched on this issue brought me to this thread, which seems to be the same symptoms I have, but the suggested fixes here did not resolve my issue.

Are there any other troubleshooting steps I could try?

I found that even being a member of dialout isn't enough to talk to a serial port sometimes. You can try removing the restrictions on the PD serial-port and see how that goes:

# sudo chmod a+wr /dev/ttyACM0

Which gives every user read/write to the port. Every time the device us removed, you may need to re-do the permissions. I think you can add a udev rule to fix it "properly", but I've never been bothered.

I've had success with this method getting Ardunio & ESP32s talking with ubuntu. So I'm guessing it might work with the PD serial link.

You can use:

# sudo dmesg

To check the name of the serial port. Sometime on repeated disconnections and reconnections it can become ttyACM1, etc.

Thanks for the reply. I tried this out (I had tried this out before but since you said it may need to be redone each time I gave it another go, as I tried it somewhere in the middle of my troubleshooting before) and it is still not working.

I did notice however that I'm getting a "Failed to terminate thread" error message as well now, but not every single time I try to open the Mirror app.