Never see the Device Menu

I understand that if you're running the Simulator and you have a physical Playdate device plugged in you should be able to see a 'Device' menu that allows you to do a range of things on the device (e.g. send the current build straight to the playdate for testing, etc.) but I've never seen that Device menu come up.

My device is registered, I can side load onto it etc. Anything else I need to do to see the 'Device' menu?

Ta :slight_smile:

Hi Stephen, you shouldn't even need the PD plugged in to see the menu (but the options will be greyed out if it's not connected). You don't see this?


At least on Mac, there is no Device menu at the top until successfully connected. (On Windows I guess it may be there but grayed out.) Either way, look for it in the top menu bar.

This button (with similar commands) is also not there until connected:

Screen Shot 2023-01-06 at 5.47.09 PM

Sometimes I have to reconnect the cord, or sleep/wake, to get the connection to work.

I'm on the Mac. I've never seen the menu option or the icon, I've tried reconnecting the cord, making sure the device isn't sleeping, etc. Nothing seems to help.

I wonder if the SDK needs to be updated?

Have you tried switching the cable? I have a couple of cable and adapter/docking station combinations that work and others that don’t.

1 Like

Ha! It was the lead sent with the Playdate! When I tried one that was a simple usb c to usb c it worked fine. When I use the yellow Playdate one, with the converter for usb c it's good enough to charge with but won't make a data connection.

Thanks Rebecca :slight_smile: