Nothing printing to Playdate sim console

I just updated my Playdate SDK to 2.1.0 and now nothing is printing to the Playdate sim console when I'm running my game. If there is an error, the console will automatically pop up but no error message will appear, the console is blank. If I try adding print statements to the code, nothing prints to the console and it is always blank. I see the same result regardless of which Playdate project I run, including the example projects. This is obviously making development harder as I cannot see any specific error messages. I am on a Mac running Sonoma 14.0. I'm happy to provide more information if necessary, thanks in advance!


I tried to reproduce on Linux with both SDKs 2.0.3 and 2.1.0: no problem here. I still get debug output in my terminal and in the Playdate Simulator console.

1 Like

I havent updated mine (didnt dare as launching game this week) but my co dev friend did and same on MacOS no console output - have sent him zip of my SDK to downgrade to 2.0.3

1 Like

Same experience here, sdk 2.1.0 with Mac OS Sonoma 14.0.

No console output.


I've got the same issue, also on SDK 2.1.0 and Sonoma 14.0.

I did find a workaround, though: because the simulator writes to stdout, if you run it from Terminal, you can see what should have been in the simulator console.

The command you'll need will look something like this:
"$PLAYDATE_SDK_PATH/bin/Playdate Simulator" /path/to/MyGame.pdx

(If you don't have the PLAYDATE_SDK_PATH environment variable set, you can replace that part with the path to the SDK on your system. The "/path/to/MyGame.pdx" part should also be replaced with the correct path to your game— a quick way to get this is to drag the pdx from Finder onto the Terminal window, which will auto fill the path for you.)

EDIT: the way this website displays the command makes it look like more than one line, but that's only an artifact of formatting– in Terminal it should be just the two paths with a space in between, like this:

Same issue for me on SDK 2.1.0 and Sonoma 14.0. I've indeed been doing the workaround you mentioned to get logs, but it would be nice if I could get them in the sim console!

I'm on SDK 2.1.0 on Monterey 12.7.1 and the console contents are visible.

Screen shot 2023-10-28 at 23.36.20

Hey all, just a quick note that we at Panic are tracking this thread and the bug, and a fix is in development. As far as we're aware, it appears to be specific to macOS Sonoma only. Thanks for reporting this, we'll try to get it resolved ASAP.


Any update? Hope the fix could be released soon

Hey Allen and everyone else tracking this fix, we're about to release Playdate OS/SDK 2.1.1 today, which will get console output working in Sonoma. Thanks for your patience, watch out for an announcement post on the forum when the update goes live.