Nova Playdate Extension error: main.lua or pdex binary required

Mac OS 14.2.1 (23C71)
SDK 2.4.0

Runs fine in VS Code!

If tried restarting Nova and rebooting the Mac.

Same error on my project and on SDK samples.

Project/Clean gives:
Could not run “Playdate Simulator”.
The extension assistant with identifier “com.panic.Playdate::panic.Playdate” failed to resolve the action.

Task Terminated with exit code 1
error: main.lua or pdex binary required
Task “Playdate Simulator” exited with a non-zero exit status: 1.

Seconding this, same thing has happened to me in Nova!

Wait one second I've got it working again. I checked a few other posts that had similar issues in the past and it spoke of how the "source" directory was not selected properly. By gods that was exactly it. I'm posting this here for any other unfortunate souls who have this issue.

Choose "Source Directory:" and select the directory which contains your game gubbins.

Thank you! I saw those posts too but didn't know there was setting for the source directory in Nova.

The question remains: why did it change and why can't Nova figure it out automatically (which is the default setting).

Since Nova and Playdate are Panic product I expect them to work seamlessly.

It should be automatic if it's called Source.

Yours is called source, all lowercase, so I'm wondering if your drive is set to case-sensitive filenames? The macOS default is case-insensitive, but it can be changed if you format a drive, or do a reinstall, etc

  1. It worked for days. What changed other than buying the license?
  2. I tried renaming it to Source and it still didn't work unless I explicitly pointed the Task at the folder
  3. It stopped working for the examples which all have "Source"

Very strange. I'm using Nova 11.8, and have never entered anything in the Source Directory, I didn't know it was a thing, so it's on automatic for all my projects.

So I think the problem is not Nova per-se, but something related. Maybe Nova Playdate Extension? Or bad SDK install? Did you install the latest SDK around the same time? I would try removing and reinstalling both from scratch.

Any just like that, I load up an old project and I get this error :crazy_face:

I restored an old version of the Playdate Extension and can confirm the problem is related to the new version of that.

I guess the extension only updated for me today, and for you a couple of days ago?

Old version Nova Playdate Extension 2.0.3 (zip) (582.9 KB)

So I've changed this to a bug report and clarified the title.

To confirm, this is a bug in the 2.4 Playdate Nova extension which will automatically be downloaded in Nova. Downgrading the extension or selecting your base/source directories manually should work around the issue until a fix is out.

1 Like

We've posted 2.4.1 of the Playdate Extension to fix this issue. Quit and reopen Nova to get the update.

1 Like