Playdate SDK for Linux?

Just had a few minutes to poke today: compile/test/install lua games works okay. C does not out of the box.

on ubuntu: apt-get install gcc-arm-none-eabi is enough to run the compile for the on-device bin (almost) but the simulator one is calling clang with dylib stuff still, and isn’t passing -lm to my main.c.

the cmake on my ubuntu 19.10 is apparently too old to rebuild the files and I haven’t done any cmake in over a decade so I don’t have time to go any further tonight. :frowning: I’ll try again tomorrow night but posting now in case anyone cares.

I also couldn’t get the simulator’s device dropdown to do anything, but didn’t try very hard yet.

I haven’t tried building C, but I can confirm the simulator’s device dropdown doesn’t do anything, and that I also didn’t try very hard to figure it out.

1 Like

The Linux build of the Playdate Simulator currently does not support:

  • Serial communication with PlayDate device
  • Loading C API games

We probably should have mentioned that earlier … :slightly_smiling_face:


well then :stuck_out_tongue: I could get compilation to work at least, but I guess there’s no point for now. thanks for stopping me, heh.

my “mac” is a VM so getting it to talk directly to the playdate requires some work. Most of my projects have or are C as well. let us know if we can help with anything :slight_smile:

Heyo, I’ve mostly got everything set up, with the help of those posts by dormando and dorthu, thanks to both of you.

Just wanted to report that the simulator screen doesn’t show anything for me, it’s just a blank screen. It runs the games just fine as I can see their console output when I run them. It’s just strange since there is no error message or similar as far as I can tell in the console. I’m currently on Manjaro with Gnome.

However I can work around that for now by testing my games directly on the device. It’s not as quick as with the simulator, but this will do for now.


Hi @toni, thanks for the report. I fired up a virtual machine of a basic Manjaro+Gnome x64 install in VMWare and I wasn’t able to reproduce any display problems.

  • Is there anything else non-standard about your installation?
  • Is the display always completely blank, or do you see the clock screen when first starting up the simulator before you load a game? And just double checking, you do see the interface (arrows, A/B, Lock, Menu buttons, etc…) and it’s just the game display that is blank?
  • Can you send the log file from ~/.Playdate Simulator after reproducing the issue?

Yes, now that you mention it, I switched x11 with Wayland a long time ago because of some display issues I had with x11 (I think it was related to screen-tearing). And to nobody’s surprise, after switching back to x11 everything works just fine.

Using Wayland, the screen is always blank, not even the clock screen renders, and I can see the interface just fine. Only the “virtual” screen is blank.

I doubt the log is any useful, since the log is exactly the same whether I use Wayland or X11, but just for completeness sake here it is: Playdate (540 Bytes)

For me personally, not supporting Wayland is fine too :stuck_out_tongue:

That’s great you found a workaround.

Interesting that the issue with Wayland is restricted to the virtual screen, as there shouldn’t be anything substantially different about how it is rendered compared with the rest of the interface. Something to look into, thanks!