PlaydateSimulator (Win10) closes immediately on launch

Howdy - After a brand new Windows10 install of the SDK, I'm trying to run the Simulator and it seems to close/crash immediately on launch. I see it briefly - the title of the application appears and a frame where the simulation window should be appears, but then it closes.

Stuff I've tried:
-Restarted machine
-Uninstalled/Reinstalled SDK
-Run as Administrator
-Looked at a couple other forum posts, but none seemed to be this same problem (or were solved with a re-install)
-Confirmed the environment variable is pointing to the right folder
-I couldn't find a log file to look at - is there one?

Try holding shift as it launches, this will prevent it trying to load the most recently run pdx.

1 Like

I have tried this as well (saw it in another post). I just tried it a couple times now and it still won't launch. Only difference in behavior is it doesn't show the frame and app name (as it did in the screenshot above). I've never run a pdx on it so I don't think it would be a conflict with it trying to run a recent one.

1 Like

Try installing the latest MS C++ runtime and see if that helps. It's found here:

1 Like

Thank you for the replies. Yes, I tried that too (had seen it in another forum post or youtube video). It didn't work either. I've switched over to using the SDK on my mac for now. Might just be some quirk with my PC's setup or a conflicting app or driver or something :man_shrugging: