SDK 1.9.3 is out!


  • Simulator: limit number of open file handles to match hardware
  • CMakeLists files provided for all C examples
  • Document performance considerations around floating point operations in Inside Playdate with C


  • fileplayer now leaves file closed until data is needed


  • Launcher: Fixes a problem that would sometimes cause an new game to animate in over top of an existing game
  • Launcher: Fixes an issue that could sometime cause an unwrap animation to be out of sync with the audio
  • Launcher: Fixes a visual glitch that could occur when the A button was rapidly pressed as the Launcher was starting up
  • Correct support info in Inside Playdate with C

As always, you can update your SDK on macOS by clicking "Check for SDK Updates…" under the Simulator's app pull-down menu. On Windows and Linux, please visit and download the new installer. (We are working on update solutions for Windows and Linux.)


Wanted to let you know that when I download the latest SDK build for Windows it gives me build version 1.9.2

Sorry to hear that. Can you let me know what country you're in?

I’m also having the same problem as @borsjt. I’m living in Norway.

When you get a chance please try it again. We've had some issues with our CDN caching 302 redirects when it should be so I have to purge the CDN cache for updates to work.

It works for me now!

Just gave it another try, but I’m still getting 1.9.2

Here's a direct link you can use

1 Like

Apologies, this is the first time I try this on this machine, so this might be a basic question!

It looks like the 1.9.3 tools shipped for Mac OS are x86_64 only? I ask because the rest of the tools (simulator, etc) seem to be universal builds, and it looks like when I try and run make in the C_API examples, I can't open in the simulator because of x86_64 vs AArch64 errors on an AArch64 Mac.

file /usr/local/playdate/gcc-arm-none-eabi-9-2019-q4-major/bin/arm-none-eabi-gcc
arm-none-eabi-gcc: Mach-O 64-bit executable x86_64

Error in the simulator:

dlopen(.../Developer/PlaydateSDK/C_API/Examples/Hello World/HelloWorld.pdx/pdex.dylib, 0x0006): tried: '.../Developer/PlaydateSDK/C_API/Examples/Hello World/HelloWorld.pdx/pdex.dylib' (mach-o file, but is an incompatible architecture (have 'x86_64', need 'arm64e'))
dlopen(/System/Library/Extensions/AGXMetalG13X.bundle/Contents/MacOS/AGXMetalG13X, 0x0115): 

EDIT: I was able to resolve this by replacing my x86_64 conda environment (Which included tmux) with an arm64 one. Apologies!

Does the SDK 1.9.3 simulator update and website link work on MacOS? I tried to download and upgrade, but the simulator says it is still version 1.9.2.

After supposedly downloading and installing the latest version of the SDK.

$ date -u "+%Y-%m-%d %H:%M:%S +0000"
2022-03-30 11:04:28 +0000
$ uname -vm
Darwin Kernel Version 20.6.0: Tue Feb 22 21:10:41 PST 2022; root:xnu-7195.141.26~1/RELEASE_X86_64 x86_64

PlaydateSDK		PlaydateSDK-1.9.0	PlaydateSDK-1.9.1	PlaydateSDK-1.9.2

I've no clue when it comes to Macs but it seems like you just need to update your path variable.

To what? After supposedly installing 1.9.3 there is not PlaydateSDK-1.9.3 directory. Last time I installed, PlaydateSDK pointed to the right version, so there was no reason to modify the path.