Trouble with toybox dependencies

I'm feeling foolish at the moment. It's been a little while since I've worked on this, but I just updated to the latest Lua SDK and tried to get my project building against it. For some reason, toyboxes aren't working for me now. When I try to build I get:

error: toyboxes/toyboxes.lua:7: No such file: github-dot-com/ebeneliason/roto/roto.lua

I have three dependencies installed with toybox. I wrote them all, so maybe there's a problem with them? They used to work, though:

Resolving dependencies...
       ->=0.0.0 <1.0.0) -> 0.2.0
       ->=1.0.0 <2.0.0) -> 1.3.0
       ->=1.0.0 <2.0.0) -> 1.0.1

Here's the contents of toyboxes.lua:

--  toyboxes.lua - include file auto-generated by (

import 'github-dot-com/ebeneliason/easy-pattern/EasyPattern.lua'
import 'github-dot-com/ebeneliason/acetate/acetate.lua'
import 'github-dot-com/ebeneliason/roto/roto.lua'

The file appears to be there:

eben ~/src/playdate/driftpin > main % ls toyboxes/github-dot-com/ebeneliason/roto          
LICENSE	Roto.lua

It's capitalized, but that never mattered before and I've tried renaming it to lowercase with no effect. I also tried removing that dependency entirely, but then the next just throws the same error. I imagine I'm missing something silly. Any pointers much appreciated! @DidierMalenfant Perhaps you can point me in the right direction?

It’s a bug in the SDK: SDK 2.0.1 breaks relative path imports? - #2 by dave


Aha. Thanks for restoring a bit of my sanity!

No problem! The github issue linked in the post has a solution until it’s fixed, you can temporarily change the paths to be relative to the source folder :slightly_smiling_face: