Cant register simulator (Windows)

When i try to register simulator, it just falls by error "Unable to register a emulator, try later". I tryed reinstalling SDK, rebooting pc, trying creating and re-creating simulators id's, and reconecting to emulating wifi. I think something more, but i forgot what. Nothing helped so far, and "just google it" didnt help too, lol.
If anyone find way out, i will apriciate if you would share it.

I just tried it and it worked here. The steps:

  1. first set up wifi in the Playdate OS in the Simulator (using test1/test1 wifi network & pw)
  2. Open "Device Serial number & Token" window
  3. Press the "Register Online..." button - it will open your playdate account webpage with a new Simulator entry
  4. From your playdate simulator entry webpage, Press the Register button
  5. When prompted by your browser, let it open the Sim and auto fill the values
  6. Verify the values are present in the Serial number & token dialog
  7. Press "Register" button

also watch out if you got multiple network interfaces, i have had issues when vmware player was installed, it installs multiple nic's and for some reason the simulator kept trying to use one of those nic's to connect to the internet which would not work. The only way i can get the simulator to communicate with panic's site is by disabling all nic's except the nic that really have my internet connection. It's worth a shot if you keep having this problem as it was the only thing that actually worked for me.

1 Like

Worked perfect!! Thanks for help!! :3
(And btw, i tryed what willco sayed, and it didnt worked.)