Crash and lockup installing 1.2 on the device

I used Settings → System → System Update. After downloading the update, it booted to the Playdate logo screen, with the top LED light flashing regularly. After several seconds of this, I got the message that my Playdate had crashed. Pushed A, and it’s booted into the Playdate logo screen, top LED flashing about once a second, and it’s been hanging there for about two or three minutes.

None of the button combos I know about will take it out of that state. Using a paper clip reset seems to reboot it, but it immediately goes back to the same logo-with-flashing-LED. (I’ve tried holding the paper clip reset for several seconds, until the screen goes blank, but it immediately boots back into the same state). Not sure how to recover from this one apart from letting the battery die.

For the record: I was running the most recent version, and I had it loaded pretty full of season one game PDXes as of last year. (So it’s likely several of those PDXes were running older versions of the SDK).

Another data point: I have it connected to USB and am running the simulator with the 1.2 update, to see if it’s printing anything to the console. Nothing in the console, and the Device menu isn’t appearing.

Hey Chuck,

Could you please try doing a paperclip reset into the data disk: Do a paperclip reset a few times in a row, and it will say sharing DATA segment as USB drive under the Playdate logo.

Assuming that works for you, could you grab the crashlog.txt and DM it to me, please?

Thanks!

I might be doing the paperclip reset wrong; I’ve tried both tapping it (it resets immediately to the same mode), and I’ve tried holding it down. For the latter, the playdate logo slowly fades out, screen stays blank until I release the reset button, at which point it returns to the same flashing-power-led mode. Is there another version of paperclip reset I should try?

Also: when I left the device alone for a meeting and came back to it, it had finally gone to the fallen blocks “Your playdate has crashed. Press A” screen. I don’t know if there’s anything I can do when it’s in that mode that’s different from when it’s trying and failing to boot.