E Y E L A N D / v2 UPDATE on itch!

Welcome to

ā€” a small "wander-around-&-figure-it-out" game.

/ / / / / / / / / / / / / / / / / / / / / /

This is my first attempt at making a video game. I was just checking out Pulp - messing around with exits and animations and got hooked. I decided to see what it would be like to make a full experience. It was fun! I would welcome any feedback, critiques.. Does it work? Is it too easy? Too hard? Boring? Better than BotW?...


So far, I've only been able to test it in the built-in Pulp player. I'm still waiting patiently for my Play Date to arrive ( soon I hope / group 2! ).


It might be a little sluggish at first. There are over 150 rooms (no kidding - many of which you're only in for a single moment) and the json is a whopping 2MB - which means it takes a few moments to load/save. Earlier versions were a little glitchy near the end of the game - and it still may be the case. I suspect it's because of it's SIZE and that my coding skillz are a bit rudimentary.

I know there MUST be better/simpler ways to accomplish what I'm doing here - I just don't know what those are! :playdate_neutral: I made it up as I went along - going back from time to time to make sure it all connected. Although it's not always that elegant under the hood, I hope that the play experience is fun.

This one will take a little while to complete. (about an hour maybe?) So DON'T close the player/emulator window before you finish, progress will be lost.

HAVE FUN! --- I hope anyone playing this finds it enjoyable, and that it isn't just my "Cones of Dunshire."

Ron Lent
Artist / Musician - NYC/NJ area
IG: ronlent

/ / / / / / / / / / / / / / / / / / / / / /

PS - THANK YOU to everyone here on this forum - I spent so much time poring over all these threads trying to figure out how to make stuff work!


This looks incredible!


ā€¢ā€¢ā€¢ā€¢ā€¢ā€¢ Thanks man! :playdate_sideways_smile: ā€¢ā€¢ā€¢ā€¢ā€¢ā€¢

This looks absolutely fascinating. Amazing job. Lovely atmosphere, lovely animations. I've been wandering around for some time.

I think I found a bug? In floor 2 of the hotel, if you press the switch but have blocked your exit and reset the maze, the elevator door closes again but the switch no longer works - returning to the room later doesn't reactivate the switch either. (Or did I forget how to use the switch??) Really digging it though.

But now I kind of want to wait and actually play it on my Playdate?!

1 Like

Looks incredible! You should add this to itch under the "playdate" tag. That's where most games are getting released now!

1 Like

Thank you so much CAI!

YES, that certainly is a bug. I fixed it

so I am pulling the jsons here in this thread

I also swapped out the link up top for this newer version in my original post (it's great that this forum lets us make edits like that)

I'm glad you're liking the game so far! It was quite a learning experience.



Thank you! That's a good idea. I didn't know that's where that stuff was being tagged.

This is fantastic! Absolutely love the aesthetic.

Unfortunately I soft locked on floor 6 of the hotel so had to stop playing there, here is a screenshot:

Screenshot eyeland softlock

I fell into that corner from below and for some reason am unable to move in any direction (even into the arrow to the left)

1 Like

Thank you, Scott! I'm glad you like it!

That's a strange one - I'll have to see if I can recreate that...

1 Like

OK - I wasn't able to recreate that problem, BUT I did notice that I could avoid the spikes on a few occasions by mashing as I "fell" --- due to a few of the strings not including ignore / listen. I fixed it and replaced it up top, but kept the version number the same...

so I am pulling the jsons here in this thread

Thanks for playing!


I made a teaser / trailer:

/ / / / e n j o y / / / /


This was really great ! I loved the artistic direction and it made me want to play ! It was even better with the animations and the UI ! I loved the ambience and all your characters (Ghoti :fish:) The sounds and music were cool too (which is a performance with Pulp) ! Loved it :sparkling_heart:
Just curious : how long did you work on it ?
I also noticed some bugs, mostly visuals : sometimes the player is drawn when it should not (in the train for example), the flale in Mountain Side was still drawn when I quitted the room. And the saddest of them all, at the end of the game I re-entered the house and get back to the dream, but I couldn't finish the game anymore :confused: I needed to replay through it to take the boat !
Keep it up to polish it, and I'm impatient to replay it on my Playdate :partying_face:


Pierre / T-Rock!

First off - thank you SO much for the compliments and for taking the time to play it all the way through! It took about 2 months on and off to make. I had no idea I was going to spend so much time. It was a challenge, an education and a lot of fun.

Second - YES, making music is TOUGH in Pulp - but, I found the brutal limitations somehow inspiring. In fact, it's why I'm so drawn to this format/device - the black and white screen / the subscription model... I can't wait for the day it finally shows up at my doorstep and I can play my own game (and all the others) on it! :playdate_happy:

Lastly - THANK YOU for the feedback. I will check out all that stuff / impliment adjustments. There where a few things that I learned a little bit late in the development that I had to go back and take care of, like ignore/listen etc. if you saw the boat, it means you only missed the VERY short credits (just me) -- also, I haven't created a proper "fin" exit yet.

again - Thank you!


1 Like

Hi Pierre - If you don't mind, I have a question - when you played it, did the sound start to break up and get distorted as you got close to the end? I'm having that problem sometimes. Wondering if it's a limitation of the online player/emulator OR if it's bad code on my part OR if my game is too big..

The "give up" sounds were loud, but not distorted I'd say. I also downloaded the .pdx and played it on the emulator, so I don't know about the online player.
But from my experience of development, and especially with Pulp, if there is a problem, it's probably in your code :slight_smile:

1 Like

THANK YOU! that helps.

I finally got around to finishing the game. Great right through to the end.

A few things I wanted to note:

  • I love the bigger-than-a-tile animations, like the one for the generator. Did you use external tools to create these?
  • The lighting in the coal mine is great :smiley:
  • The way you fall down once you get to the lighthouse is really neat.
  • The rain on the other side of the mountain and the way it works was really unexpected and nice.

I also noticed the following tiny, non-breaking bugs:

  • In the gravity hotel room, the final arrow you touch on the way back to the elevator lets you sidestep while falling, which from posts above it sounds like you are trying to avoid.
  • It's possible to "get" the can of WD-40 more than once if you keep going back to the same NPC.
  • The room with Xennifer wraps vertically like the subsequent rooms do ā€” not sure if that was intentional. It didn't seem totally out of place.

That's it. Great job again!

1 Like

C A I !

Thanks for taking the time to play through and organize these detailed feedback and comments. I really appreciate it! and thanks for hiding spoilers!

the bigger animations were mostly all by hand - tile by tile, frame by frame. it's a bit tedious, but my brain can "see" things that way. the lighthouse top was originally drawn frame by frame in photoshop, so I could work bigger than 8x8, test the animation as a whole, and make sure it looked right ā€” THEN, hand-drawn by referencing the psd ... tile by tile! whew.

Glad you appreciate those surprise/nuanced moments. I really wish I knew a better way, technically, to do the "coal mine lighting"ā€” other than creating a new room for each position. It's crazy, but it works. I started trying to do each position in one room as an "on interact, swap swap swap tiles" that was even MORE ludicrous - haha. I'm sure there is a better way, I just don't know it!


I need to fix those things, you're right, the first two were not intended - thanks for catching those.

the last one is intentional, but maybe there is a better way? I want to keep you going in one direction (because it's near the end) BUT I was trying to make it feel open, so I didn't want to have walls all the way through. also, I kind of like that reality is a bit odd on this side of the island... maybe there is a better way.

thanks again!

1 Like

Love the cinematic touches and little artistic effects everywhere! I played a bit (completed the hotel), side by side with the code open in Pulp to see how some things were done, so thanks for the learning experience.

Small bugfix -- I looked at the code for the Hotel 1 area with the warp pads (since I didn't want to trial and error my way through lol) and found that the sprite named "unblocked" has code that isn't being called, looks like it should be on "interact" instead of "collect" since it isn't an item. On the subject of hotel floors, the ones like 2, 5, 6 that didn't require much trial and error were my favorites.

Also, in the original post it says "don't close the window" but maybe it's possible to save state across play sessions using "restore"? Dunno if you've tried that. Anyway, great job making this! :smile:

Edit: Played a bit further and found another bug:

(minor spoilers)

In the facility with the werkbots, after talking to the bot on the bottom and getting zapped, the bot on the top said "hey", "HEY", I could've gone up and talked to him immediately but I stayed on the bottom and zapped myself a few more times first. When I did go up to talk to him he just said "I've got nothing" instead of giving me his battery, and I was unable to progress. Maybe some variable state got messed up in there. Also, the dialogue boxes for Werkbot A sometimes read "Werkbot B", maybe a relic from copypaste.

1 Like


Thank you! I'm so glad you liked it. I have to say, I'm a little worried what bad habits you might "learn" from my cobbled-together, ugly code - :laughing: BTW, those are my fave hotel floors as well.

I have to learn how to implement "restore", that's still a bit of a mystery to me. Also wondering how to use "toss". Learning as I go.

Thank you for your bug report: NICE CATCHES! Those are ALL unintentional and I will address them. The facility was a particularly hard one to keep track of. Trying to allow the user to explore stuff in any order before it starts to hand you some help almost broke my brain!

1 Like