"error: compress failed: buffer is empty" error from pdc in SDK 2.0 beta 2

Hi, I installed SDK 2.0 beta and would like upgrade my Zig template for Playdate to work on firmware version 2.0. However pdc is now giving me an error: error: compress failed: buffer is empty.

This is the pdc command I am running pdc --skip-unknown zig-out/Source zig-out/example.pdx. The contents of zig-out/Source: is

$ ls zig-out/Source 
pdex.dylib         pdex.elf           pdxinfo            playdate_image.png

Any ideas on what is causing this error? I updated the linker.ld file to match the new linking format of the 2.0 ELF files. Apologies for tagging you here, @dave. But I feel you might have the most insight here.

Thank you!

I installed zig 0.10.1 (on the Mac via brew) and the example project built without an issue using the build.0.10.1.zig build file. Any chance the build.zig file has some-sort of error?

Thanks for checking that out! Unfortunately, I did the same thing as you and got the same error message:

➜  Zig-Playdate-Template git:(main) ✗ /opt/homebrew/bin/zig build  
Skipping libpdex.dylib.o
Skipping pdex.bin
error: compress failed: buffer is empty
The following command exited with error code 1 (expected 0):
cd /Users/danielbokser/Downloads/Zig-Playdate-Template && /Users/danielbokser/Developer/PlaydateSDK/bin/pdc --skip-unknown zig-out/Source zig-out/example.pdx 
error: UnexpectedExitCode
/opt/homebrew/Cellar/zig/0.10.1/lib/zig/std/build/RunStep.zig:277:17: 0x100f5730b in runCommand (build)
                return error.UnexpectedExitCode;
➜  Zig-Playdate-Template git:(main) ✗ /Users/danielbokser/Developer/PlaydateSDK/bin/pdc --version                                        

The pdc you are using is also 2.0.0-beta-2?

I was. Do you happen to know if zig uses makefiles behind the scenes?

it does not. the build system itself is written in Zig

Also, one thing to note, is that if I run pdc manually I get the same error. So I doubt this has anything to do with the build system, and more to do with the contents to the Source folder, or the installation of pdc iteslf. Is it possible you could send the contents of your zig-out/Source folder so I can compare?

What OS are you building on? Let's start there. The error you're getting is new in 2.0, I just need to figure out why you're getting it and I'm not.

One thing to try, remove the skip unknown flag. Does that make any difference?

I am using macOS Ventura 13.3.1. I also tried with removing the --skip-unknown flag and same error unfortunately.