Games not showing in simulation

When I boot up the simulator under Linux, the Settings 'game' isn't showing. I also get an error in the console saying "Error: row index out of range 2". When I installed the simulator on my laptop, it functions properly, showing the settings 'game'. Reinstalling does not fix the problem.


I figure this is a bug with the "Launcher.pdx" 'game'.

Hi, it sounds like perhaps your Disk folder is damaged. Can you move aside your whole SDK folder and unpack it again from the tarball?

Also what Linux are you using?

I am using Ubuntu Linux

I unpacked the SDK fresh, and deleted the ~/.Playdate Simulator folder, and it still happens.

@willco @dan Any ideas?

If you open the Console in the Simulator, does it show an error?

It does look like Settings.pdx is missing. What does your Disk/System/ folder look like inside of your installed SDK?

yes, it shows in one of the screenshots that I get an error "Error: row index out of range 2"
And it seems like the Disk/System has things in it.


I wonder if my shell has anything to do with it. I am mostly using Fish, however, I always make sure that Bash's env variables are correct too. I tried running setup.sh with both fish and bash in separate install attempts too.

Your shell has no impact. What file system are you running? What version of ubuntu are you using?

@DavidMedin I saw in another one of your posts you had the Simulator running correctly, is that right?

I believe I am using ext4, and I am using Ubuntu Budgie. I've added a bunch of things, so I'm using bspwm.
Yes, it works on my laptop, not on my desktop. My laptop and my desktop are extremely similar in setup, I don't know the difference that matters.

I've also dual-booted windows in my laptop, and I've confirmed that on my laptop running Windows, I can get the simulation to work exactly correctly that solves both my posts, just not for Linux. My games show up, and I can add games by putting games into Disk/Games. Though this isn't on Linux, which is what I want.

Did you install the Simulator on your primary drive in Linux?

Yes, I put the SDK in /home/david/libraries/playdateSDK, which is on my main SSD, mounted to /.

I have found that having a game that I made in the Games folder of name "InputTest.pdx" shows it in the launcher. I also compared my laptop's and desktop's System/Data/Games.json files and found that the 'Settings' game was missing from my desktop's System/Data/Games.json file.

As I have mentioned in my other post, the .pdx folder name is case sensitive, and needs to be lowercase. However, settings still doesn't work, and my desktop is still nuking 'settings' out of its Data/Games.json.

@DavidMedin Could you make sure the contents of your Playdate SDK folder is user writable?

Yes, it is. Also, now that my game in Disk/Games is lowercase, the "Error: row index out of range 2" error has disappeared.

Is your file system case sensitive (or not) on both your laptop and desktop? As you've found, the .pdx extension does need to be lower case.