Games not showing in simulation

yes, it shows in one of the screenshots that I get an error "Error: row index out of range 2"
And it seems like the Disk/System has things in it.

I wonder if my shell has anything to do with it. I am mostly using Fish, however, I always make sure that Bash's env variables are correct too. I tried running with both fish and bash in separate install attempts too.

Your shell has no impact. What file system are you running? What version of ubuntu are you using?

@DavidMedin I saw in another one of your posts you had the Simulator running correctly, is that right?

I believe I am using ext4, and I am using Ubuntu Budgie. I've added a bunch of things, so I'm using bspwm.
Yes, it works on my laptop, not on my desktop. My laptop and my desktop are extremely similar in setup, I don't know the difference that matters.

I've also dual-booted windows in my laptop, and I've confirmed that on my laptop running Windows, I can get the simulation to work exactly correctly that solves both my posts, just not for Linux. My games show up, and I can add games by putting games into Disk/Games. Though this isn't on Linux, which is what I want.

Did you install the Simulator on your primary drive in Linux?

Yes, I put the SDK in /home/david/libraries/playdateSDK, which is on my main SSD, mounted to /.

I have found that having a game that I made in the Games folder of name "InputTest.pdx" shows it in the launcher. I also compared my laptop's and desktop's System/Data/Games.json files and found that the 'Settings' game was missing from my desktop's System/Data/Games.json file.

As I have mentioned in my other post, the .pdx folder name is case sensitive, and needs to be lowercase. However, settings still doesn't work, and my desktop is still nuking 'settings' out of its Data/Games.json.

@DavidMedin Could you make sure the contents of your Playdate SDK folder is user writable?

Yes, it is. Also, now that my game in Disk/Games is lowercase, the "Error: row index out of range 2" error has disappeared.

Is your file system case sensitive (or not) on both your laptop and desktop? As you've found, the .pdx extension does need to be lower case.

Both systems are Linux, so they are both case sensitive.

Hello, I have exactly the same problem ^^.

Please install SDK 1.10 and then hold shift when opening the Simulator and let me know if you continue seeing this issue, thanks!

I switched to 1.10.0, and the Settings game still doesn't show, but my game that I made does show under My Games.

Could you attach the Console Log output when opening the simulator? Do you have unicode in your SDK path?

I believe you're running into the bug listed in this post: playdate.file.listFiles() only showing some files - #8 by salty-horse

That could be. Though it is strange that this isn't happening to anyone else. And to answer your previous question, I don't have any unicode in my SDK path.

Here is my log when I boot up the simulator. There are no apps under System when I press S or W.

Yeah, we've never seen the OS listing a directory 'out of order' when testing on Ubuntu, but a couple people have reported it. Seems totally luck of the draw...or unluck as it were. What I believe is happening is your Settings app is one of the first two results when listing this directory and so it's getting removed from the list of system games.