Installing SDK on earlier MacOS versions?

Hi, I'm using High Sierra (10.13.6) and the installer says 10.15 or later is required. Is this down to the compiled SDK code and/or the Xcode linkage, or is there a way around this?

I would update my workstation, but I use a lot of 32 bit software for my work, software that has dropped features in newer versions, which forces me to stay behind for now. Would love if I could somehow get the SDK working on this slightly older OS version, but if it isn't possible I understand.

Thanks for the help!

1 Like

Whilst it's possible to persuade the SDK to install on older systems the current version of the Simulator requires modern macOS.

This is annoying, because SDK 1.7.0 (the previous version before 1.9.0) worked OK on my Mojave MBP.

2 Likes

If there's no inherent reason why MacOS > 10.14 is required, is there a chance 10.14 might get support again in a future update?

I am also stuck on pre-10.15 to maintain compatibility with some irreplaceable 32-bit software. (shakes fist at Apple)

1 Like

Or alternatively, are the old versions of the SDK (e.g. 1.7.0) still available to download? I’d really love to be able to play around with the SDK before my Playdate arrives but right now step 1 is start saving for a new computer :confused:

I'm sorry, but Panic is against distributing old versions of the sdk.

1 Like

That’s disappointing.

Well then I guess I’ll just have to hope that future versions of the SDK have expanded compatibility. (Or that I win the lottery and can buy a new laptop.)

Well, no rush! Let's wait and see if they can officially do something about it. For all we know it might be pretty easy to add legacy support back in at some point. There will definitely be more updates to the SDK considering it just released.

1 Like