Issue with toybox

This is my first time using toybox. I'm trying to add the "pplib" dependency to my Playdate project. All my toybox add pplib and toybox install commands are giving me the error: “Error fetching default ref (status 404)”. I've tried running toybox login with both "fine-grained" and "classic" GitHub access tokens, on the off chance that GitHub access was the issue, but neither of those changed anything (other than not printing out the GitHub API quota message.

I've tried to add another package, just to see if it was package dependent, but I get the same error.

This is with toybox v.0.0.3


P.S. I see that the format for adding packages seems to have changed since @frankbsad wrote up his documentation for pplib and that now you need "owner/dependency". I changed my command to "toybox add jm/pplib " and also tried "toybox add jm/pp-lib" (since that's the name of the GitHub repo) but neither change seemed to have any effect.

I think you'll need to talk to @DidierMalenfant

Thanks, @matt! Hopefully they will see this thread.

Maybe related to this, I am a little confused about whether I should be using the version of toybox at GitHub - jm/toybox: A dependency management system for Lua on the Playdate. or the one at | Didier Malenfant’s Website. I was using the former, but now I'm guessing that maybe I should be using the latter, since it appears to be newer than the last commit to the former.


Definitely Didier's version

Makes sense. I'll try again with that. Thanks!

Yeah, that worked. Thanks again!