Mirror does not detect game controllers D-Pad

Mirror version 1.1.0
The A and B buttons work on the game controller but not the directional pad (D-PAD).
Tried to customize buttons but it does not detect the D-Pad buttons at all.
I've tried multiple 8BitDo Zero 2 controllers as well as the 8BitDo Pro SNES.
It works with the Steam Controller but only if you set the D-PAD to the arrow keys via other means.

To confirm, you have Controller -> Game Controller selected in the main menu? What OS are you on?

Yes, that's what I have it set to.
Running latest Windows 10 build.

I tried an 8BitDo Ultimate wired and it worked as expected as well as an Xbox and Gamesir controllers. I don't have a zero or Pro but I suspect they should work. You could try downloading a new game controller db found here (GitHub - mdqinc/SDL_GameControllerDB: A community sourced database of game controller mappings to be used with SDL2 Game Controller functionality) and replace the gamecontrollerdb.txt file in the Mirror install directory and see if that helps at all.

I replaced the Mirror gamecontrollerdb.txt with the GameController SDL2 one and it did not work.
I also copied the outputted game controller entry (by going through the mapping steps).

The result looks something like this:

030000005e040000e002000000007801,8BitDo Zero 2,a:b0,b:b1,x:b2,y:b3,back:b6,start:b7,leftshoulder:b4,rightshoulder:b5,dpup:-a1,dpdown:+a1,dpleft:-a0,dpright:+a0,platform:Windows,

I then added this to the Mirror gamecontrollerdb.txt (in the Windows OS section) as well.
Re-tested the SN30 Pro, that seems to work now. But the 2 8BitDo Zero 2's don't work with it.