No output when compiling using pdc on Windows

I'm just starting out with the dev tools, and running into problems trying to compile a game to run in the simulator on Windows. Here are the steps I took:

  1. Downloaded and installed the SDK (2.4.0)
  2. Added the SDK's /bin/ folder to my Path to be able to run pdc from anywhere, as well as PLAYDATE_SDK_PATH and PLAYDATE_LIB_PATH environment variables pointing to the root SDK folder
  3. Made a folder on my Desktop named "TestGame" that contains a main.lua file whose contents are copied from the "A Basic Playdate Game in Lua" section of the docs
  4. Opened a terminal at my Desktop and ran "pdc TestGame TestGame.pdx"

However, when I do this, nothing happens. The process finishes, there is no output, error or otherwise, in the terminal, and no output directory is produced on my Desktop. I know pdc is working because I can run "pdc --version" and get the output I expect (2.4.0)
Here is what I have tried to resolve the issue:

  • Running with the -v verbose flag
  • Running the command on several of the example projects in the SDK
  • Running different variations of the command doing things like leaving out the output folder (which apparently should work and default to [input name].pdx for the output) or even purposely using input directories that don't exist (in an attempt to force an error)
  • Restarting my machine in case there is some hanging process running in the background causing these issues
  • Searched my machine for any folders named "TestGame.pdx" in case the output is going somewhere else

None of these seems to have caused a change. No output is ever produced in the terminal window.
Once or twice, seemingly randomly, a .pdx folder has been produced on my Desktop, but it is completely empty.
I suspect something is failing silently, but is there any way I can get any more information on what is happening?

I managed to fix this shortly after posting and figured I would post the resolution in case anyone in the future saw this.
I uninstalled the SDK (using Uninstall_Playdate_SDK in the SDK folder), then searched for "playdate" on my entire drive (using WizTree FWIW) and nuked every file I could find that looked relevant. After that, I reinstalled the latest SDK and everything seems to be working now.
There were a number of files in my AppData/Local folder that I think may have been the culprit. Not sure how they would have gotten into a state that would have broken pdc in the way it did, though.

Actually, this wasn't the cause! I went through adding all of the environment variables after getting things working directly from the SDK's bin folder and I was in a broken state again. I deleted the PLAYDATE_LIB_PATH from my environment variables and then I started getting CoreLibs errors when I ran pcd again. However, if I specify the SDK folder either through -I or -sdkpath, everything compiles correctly.
Not sure why PLAYDATE_LIB_PATH wasn't working in my environment variables, but I am fine having to specify the SDK path when I run pdc, as long as it works.