Playdate SDK Installation Not Working On Mac

I'm new to developing on the Playdate and have been trying to install the Playdate SDK on my mac. The first time I tried, I left my computer running on the charger overnight and it still hadn't made progress after about 24 hours. (During this first attempt the bar hit about 70% completion and then froze for the rest of the day.) After a whole day, I decided to try restarting to see if that would fix it (I force quit the Installer and reopened it.) Everything works until it starts to install again. Every time I try installing it, it just says that it's waiting for other installations to complete. I've tried restarting my mac, restarting the installer, and finding any of the files that had already installed and deleting them to try and fix it. Is there anything else I can do to fix it and install the SDK?

This can happen when a previous installation (possibly for some other software) fails to clean up after itself. You could try the top answers here:

Or booting in Safe Mode:

If those don't help, let me know and we'll try to dig deeper.

That seems to have fixed the problem. Thanks!