SDK on linux suddenly running at 100% CPU

I'm not sure what happened, but after updating to SDK 2.4.1 on Ubuntu Linux recently, the Simulator has been running realllly slowly, and at 100% CPU.

Reinstalling / running the older 2.3.1 doesn't seem to fix it, but I'm not sure what might be causing it. Has anyone else experienced this, or might be able to help?

What DE are you running? Are you running KDE by chance?

@willco I have Plasma installed, but am running Gnome on Xorg. I tried running it under Wayland as well as using the i3 desktop manager, but seem to get the same issue.

Boy, I don't know. You could try running perf and seeing what it says. If you downgrade to SDK 2.1.1 does the behavior go away?

1 Like

Aha, 2.1.1 acts fine, so maybe I just didn't use 2.3.1 much before and didn't notice it. Thanks for that, it's a good start!

I'll have a play with perf later on to see if I can see anything obvious...

OK, good to know. Something is causing excessive menu item validation on your system which is causing the slow down. I've added a 'fix' in SDK 2.5 for another user with the same issue already, but if possible, disable anything that might be messing with your GTK menus.

Hi again - finally just got round to upgrading to SDK 2.5, but still getting a lot of slowdown in the simulator. Any tips for debugging or fixing this further, or how to check for anything messing with the menus?

Cheers!

At this point, the best thing to do is run perf on it and post some results. I need to see if I can spot a slow down on your system some place.