[SOLVED] Unable to run Simulator on Windows - SDK Path Not Set


I just installed the Playdate SDK on Windows 10, and am trying to get started with some examples. Unfortunately after closing the first launched instance of the simulator, when I tried to register the simulator, I started getting this pop-up. I have set the Environmnet Variables (tried both System and User) as well as launching as Administrator, but I keep getting the pop-up.
I've tried to set the path via the pop-up, but no matter which folder I try, root or otherwise, it keeps complaining.

What can I do?

I have the same problem

Did you install the SDK on your C drive or a secondary drive?

You should be able to select the PlaydateSDK folder when prompted. If it continues to error, try re-installing the SDK (perhaps something was corrupted on Disk) on the C drive.

There has been a bug reported that if you have the SDK installed on one drive, and your build directory on another (on Windows at least) that you will have compile fails. I have my SDK and a separate folder at the same lvl, but both on the same disk (and not my C:)


SDK was installed on my D drive. Uninstalling and then re-installing on C fixed the issue.

1 Like

Thanks @Robert123 I was running into this playdate path not set issue, I moved my project folder to C: (same drive as my SDK) and the simulator is now running !