Stuck on "Account Linked!" after System Update

Hi,

I’m certain I represent an unusual edge case. I received a playdate sometime last year and didn’t start playing with the SDK until a couple days ago. Today I encountered the following:

  1. My computer (Win7 (yes, I know)) could not install a driver for the device automatically
  2. I attempted to register my device by following the instructions. When I navigated to play.date/pin my login credentials for the devforum didn’t work. I had my friend register the device as hers instead.
  3. After registering, I tried to run the system update. The downloading progress bar got stuck at the ~95% point and the device crashed. It showed a message about something something 10s.
  4. After restarting, I ran the system update again. The download and unpack finished. And the little cute fireworks animation played. I started the wizard and entered the credentials for the WiFi. However, the third step in the wizard has always looked like this:

    Not sure how to get out of this.

The device is very cute and I like the simulator, I’m excited to make something weird for it!

OK, I was able to get past the stuck wizard screen by resetting the device! Now the biggest issue is that I don’t have a driver for the device.