Trouble connecting to wifi

Finally sat down to figure out how to get to hello world, and I’m blocked on step 1: connect wifi to update. It doesn’t see my wifi automatically, and gives me a “can’t connect :(” after I manually enter the name and password. Is there a way to update it via USB?

It’s crashed a view times in this process too. Error messages include:
wifi/wifiview.lua:310: attempt to access a nil value (upvalue ‘menu’)

wifi/wificonnectprogressview.lua:55: attempt to access a nil value (upvalue ‘controller’)

(currently running SDK 0.10.0-beta.2+d99fce682404)

I also have an issue to connect my playdate to the WiFi which mean I cannot update the device to 0.10.1

When it scans the networks names I get a Wi-Fi Error.


The debug output:

scanning...
got result...1
---------------------
	table: 0x6003c9e0

FYI there is plenty of WiFi around me so getting only 1 result would be strange in itself

When I enter the network name and password manually, it is just stuck on the connecting screen. Playing with the menu button I notice the screen had massive flickering so I wanted to record it and it just crash in front of me.

IMG_0687.2020-05-11 22_21_37

Is there a way to update the device to 0.10.1 manually?

I managed to get onto wifi and update, but after reset it had forgotten my wifi again.

Hey @Nic
It looks to me like the wi-fi chip in your device wasn’t successfully upgraded when you went from 0.9.x -> 0.10.0. While this is something that is reliable when doing Wi-Fi firmware updates, it sometimes has issues when updating through the simulator.

Could you please do the 0.10.0 update through the simulator again, ensuring that you get a dialog indicating success before proceeding?

1 Like

@matt
The good news is that even though the UI doesn’t demonstrate that it remembers your ssid/password, the device actually does. Your Playdate will automatically connect to it on-demand, without user intervention. You could verify this by just going straight back into Settings > System > Check for System Update and seeing that it doesn’t communicate an error back to you.

We’ve got a couple of open issues regarding the UX around this and hopefully can make it a bit more user friendly soon.

1 Like

ok I have this error message

Screenshot 2020-05-12 at 17.25.50

Same as last time.

I re-installed the latest command line tools and the update 0.10.0 was properly done. At first the wifi was still not working but after restarting the system I could connect to the wifi.

Thanks @marc

So! I escaped all the special characters (ie, * instead of *) in my password and then everything went fine. Did I need to do this? Did I maybe just type my giant dumb password wrong the first three times? Hard to say. But it’s working now.

I’m having wifi issues also. Just got the device, with the 10.2 update. It connects sometimes, but then forgets/loses the wifi. Can’t get it back. I tried the update to current sdk via the simulator, but get the following error.

Couldn’t update device
Didn’t find firmware folder for this device at Firmware/dvt1

That error is expected when trying to update via the Simulator.

Our Wi-Fi expert @marc is out of town this week, but will be back next. The good news if that if you are running 0.10.2, that’s the latest firmware, so there is nothing you need to update to!

Please check if your WiFi network uses 2.4 GHz & not a 5 GHz frequency. This was the issue in my case.