Trouble with pladate pdx files

So when i downloaded and tried to load some pladate pdx files on the simulator it keeps giving me a prompt saying this is not a vailid SDK path did i forget to do something? what do i have to do to the files to make them load up on the simulator can someone please tell me.

Firstly, the terms of use of the SDK (and simulator) are that you use it for development of your games only. With that said, there are many reasons why a PDX might not work in the simulator, but the main one is that it contains native libraries that weren't built for your platform (e.g. developer built on Windows and you're on a Mac). I haven't encountered this particular error so I can't help beyond that personally.

This implies the SDK is not installed correctly.

What platform are you using? Mac/Windows/Linux?

Try reinstalling the SDK again.

I am using a windows computer

Have you tried the solution suggested by Willco?

This is a duplicate of the other thread in which I replied in. Closing this one.