Unable to mount Playdate in disk mode?

@willco Any other troubleshooting steps we can take? Secret button combos?

I think we'll have to RMA these devices to get a hands on look at the issue. Please contact support to start the process. Sorry for the troubles.

@dfbills @davidcox I did have one more thing to try. If you hold left d-pad and lock + home, when the device reboots into disk mode does it show up?

@willco No dice in Finder, Disk Utility, or Playdate Simulator.

I submitted a support request today.

@willco thanks for the suggestion. I tried this on 1.11.1 and 1.13.2 but was still unable to get the device to mount. I'll reach out to support to RMA -- thank you again for your help.

@willco Is there a trick to getting support to respond? I've never had a reply to any request that I've made, including my recent RMA request...

No magic, check your spam folder. If it's not there, please DM me email address and I'll see if it's stuck in our spam folder. :slight_smile:

1 Like

@willco I received the replacement and while it didn't work immediately (and I was heartbroken) it is NOW WORKING!

I noticed when it connects to the Mac the Disk Mode screen says "Eject disk to reboot." On the one that isn't functioning, it just says "Press A to reboot."

Mirror seems to crash quite a lot, but after restarting it several times, it does connect to the new unit as well. I've attached the Mac Console logs for the Mirror crash. Mirror Crash Console.log.zip (3.9 KB)

Playdate Simulator is also able to read the new device without issue.

Now, if the data from my original device can only be recovered....

Hey, I read through this post and saw that the issue wasn't really resolved. I'm having the same issue with my mac (Sonoma 14.1.2) not reading the disk of my playdate (2.2.0)

When i press a to reboot out of disk mode the device crashes. The Simulator reads the crash to the console log.

preforming diskutil list in terminal returns the data
/dev/disk4 (external, physical):
0: FDisk_partition_scheme *3.7 GB disk4
1: Windows_FAT_32 PLAYDATE 3.7 GB disk4s1

So i know the mac sees it. i jut need help reading it

((EDIT)): After restarting it and it crashing several times it just worked.

I ended up having to get a new unit from panic. I lost all my data and frankly lost my enthusiasm for playing since I lost all my save states.

Hey! I dunno if it may help or not, maybe it's too late but I happened to come across this same issue and I got to read this thread, in my case the Playdate wasn't being able to be mounted on the Mac, just as happened to @Rusty and @dfbills, however I noticed that I had the simulator open when attempting to mount the Playdate, as I was coding some stuff.

In my case what 'solved' it was just Cmd+Q the simulator, then restarting the Playdate (which was in Data Disk mode, apparently not working as dfbills mentioned with the 'Press A to reboot' message), then at the next attempt it just mounted, with the "Eject disk to reboot" saying.

May it be that the simulator just had to be fully closed in order for the device to mount properly?

Hey man, thanks for the post. I got a new playdate way back then and lost all my saves. Sadly this kind of broke my love of the device. I have hardly played since this event and have often thought of selling it… :frowning: