Crash loop on boot after attempting update from 0.11.1

I just tried to update my Playdate to the latest version over Wi-Fi. It was on version 0.11.1 before. It's very similar to this thread: Won't boot after system update "invalid bootloader file"

Basically when the device boots up it says "Applying update / This may take a minute…or three," but then the notification light turns red and it reboots. It does this over and over. So far I've tried deleting boot and pdfw from the boot sector, and restoring the pdfw.bak and boot.bak files that I found there. No dice, it flashes successfully but then it enters the same crash loop, and when I open the boot drive again, they've been renamed back to what they were. I can't get it to boot. If I hold down the reset button a really long time, like 10s+, I can get the classic crash screen telling me to press A to reboot, but it still tries to update and can't.

Would love help resolving this. I'm sorry I haven't picked up the device in over a year.

Update: left it overnight and it's still doing it this morning.