Device boot-loop / possible launcher bug?

Upon waking the PD this morning with the "new games available" light and message on the lock screen. the PD was unresponsive for a few seconds then crashed. It proceeded to crash again after a few frames of title card animation, or after any attempt to go up or down in the game menu.

After a few iterations of this (having managed to move a few games down in the menu) it now crashes consistently quite quickly on reboot. A long-press of the reset button under the crank does not seem to change the situation.

The trace indicates

games.lua:127 field '' is not callable (nil) in field 'loadHighlightImageForFrame

I had recently web sideloaded two games "Heavy Drinker 2023.4.26" within the last two days (without touching the PD) and "Voxel Space Playdate" maybe 30m prior to picking up the PD - very possible that this one wasn't downloaded yet.

Any ideas on how to recover from this? I believe I'm on the latest v1 FW.

Video of issue:

Thanks! Tim

I can't trivially reproduce with "Voxel Space Playdate". If you scroll down really fast before it crashes does that do anything? I think 'loadHighlightImageForFrame' displays highlighted images for the selected game, so switching the selected game may help.

You should still be able to trigger a reboot into disk mode (use the Simulator to do so) and confirm the offending game by removing it.

Thanks - yes, if I am quick then I can use this to get into the data disk mode.

I tried copying out and emptying the entire Games/User folder and the entire Data folder.

Confirmed that the most recent sideload game - which may or may not have been the cause of the issue - was user.50181.pulp.intellikatsgeosbeepsnboopsbitflung.heavydrinker2023426.pdx

Now it boots to one of the season games on the launcher, but it still crashes as soon as any attempt is made to go up or down in the launcher, launch a game, or choose any option from the menu.

Does anyone know if it is possible to trigger a factory reset from this state?

I have not been able to get the A+B+Menu+Lock from Recovery Mode - Playdate Help to work

I sideloaded Heavy Drinker via Website too and got the exact same crash reports.

The A+B+Lock+Menu did work for me. When you hold those buttons for a while it will say on the screen to press Lock+Menu to install recovery firmware or something, so you need to let go of A and B and only keep holding Menu and Lock.

I copied and deleted the data folder and game folder trying to fix my seemingly bricked playdate. I got a different crash report in the end with only the "settings"-tile beeing displayed after each crash. I missed taking a picture, something with "#1 colour nil".

But after letting the playdate sit for an hour or two i came back and it showed on the lock screen "new update available" and it was working again. Could update to newest firmaware, install all games again and copy my savegames back in the data folder.

So try to get that recovery firmware installed with the button combo and then let the playdate sit for a while till it gives the "new update" on the lockscreen.

Hope you can fix it and maybe we should warn in the discord about heavy drinker i think (or is it just us and we made something wrong?). I was relieved when mine stopped crashing.


I’m having a similar issue and also recently installed (but haven’t played) Heavy Drinker. I can still get to data disk mode so I’ll check to see if removing it helps.

Edit: yes, doing the same steps as JimmyPlacid fixed my Playdate. Specifically:

  1. I used the simulator to get to data disk mode (Device > Boot to data disk), deleted /Games/User/user.6119.pulp.intellikatsgeosbeepsnboopsbitflung.heavydrinker2023426.pdx, and emptied the trash (I hadn’t actually launched the game, so there was nothing in /Data from it. If you’ve actually played it you might need to remove its data from there too)
  2. Went to the side load page and removed Heavy Drinker
  3. Ejected and unplugged the Playdate
  4. Tried to open Settings, it crashed and rebooted to the setup process which had me re-enter my wifi password
  5. I held Lock+Menu+A+B, then let up on A+B when prompted, to install the recovery firmware
  6. like JimmyPlacid, my recovery firmware also crashed any time I tried to open Settings (though mine did not show a crash report, just the plain crash screen), so I locked the Playdate and waited for it to check for updates in the background. I think around this point I also tried holding the reset button in the crank slot for 10+ seconds, which didn’t help.
  7. It eventually did the automatic update check, then crashed on the lock screen, automatically restarted itself without my input, and showed the “system update available” banner
  8. I opened Settings (it didn’t crash this time) and updated to 1.13.7, which now works fine (it lost the Catalog app, but I could redownload it from Settings > Games).

I’m not actually sure if going back to recovery firmware was necessary. I suspect that it just needed to do another background update check after step 3 to clear out some cached reference to Heavy Drinker.


Thanks guy-- I'm going to look into this to figure out what the issue is... putting the download on pause for now until sorting it out.

1 Like

mine did it too, i can confirm it is from heavy drinker, mine started acting up mid-installation . now its stuck in the same crash/reboot loop.

whats strange is theres no heavy drinker game folder nor data folder present, as if it never got around to actually putting the files on my system, but its still stuck in the reboot/crash loop.

i deleted all my data and game files anyway, and held down the 4 buttons to trigger the recovery firmware, but thats crashing too as soon as the system boots up

update: after sitting idle for about an hr, it prompted me that an update was available, and didnt crash this time long enough for me to go to settings and actually update the firmware

im now reinstalling all the games and everything seems to run fine again

thank you for this page full of helpful advice guys
id never even touched the pc playdate emulator before today:)

Perhaps you experienced it with Heavy Drinker, but we don't think it's game-related. We took a look through the code today and ran it to look for any issues and nothing came up.

i'm struggling to understand the firmware update process others have used. since i don't have real hardware yet i've never seen the process...

was heavy drinker distributed just before a firmware update rolled out? any chance the pulp export required that update and so everything was borked until the update was installed? or are users installing heavy drinker on systems with the latest firmware, experiencing issues, shifting to a recovery image, then updating to the current firmware again in order to fix this issue?

did you run it on a playdate console successfully ?

Thanks @daprice - I'm struggling a bit on #7, but this looks to be the process.

I might delete all season games later to make the update banner move up as this morning I hit a wall in trying to scroll down below Saturday edition - it's crashing here before I can scroll at all.

My partner did without issue. Unfortunately I don't yet have my console :frowning:

1 Like

Hi @intellikat - it's strange, I don't think anyone knows yet exactly what it is about that PDX which is causing issues with the launcher.

The boot-loop might also only get triggered when this PDX is sideloaded via the website (this is how I installed it).

To help the panic folks debug the cause of the issue, could you say if there was anything unusual at all about your workflow. I.e. did you make any changes to the files in the PDX after exporting them from pulp? And approximately what date did you do the pulp export?


Just a random guess, but maybe "intellikatsgeosbeepsnboopsbitflung.heavydrinker2023426.pdx" is too long of a filename?

1 Like

No changes after exporting. The time of the original upload was two days ago.

Hmmm. Went ahead and changed that to see.

Hm - interesting suggestion @Nnnn, I can certainly see something like that being a potential source of problems if anything in the code is expecting only 64 characters max and gets 74.

And it could also explain why the bug would only affect sideloading via the website - the sideload procedure is what generated user.50181.pulp.intellikatsgeosbeepsnboopsbitflung.heavydrinker2023426.pdx. Had I copied it over USB then I would have had the much shorter Heavy-Drinker-2023.4.26.pdx which could explain why @intellikat's partner wasn't affected?

I took a look at the zip I had downloaded the other day and the bundle id seemed too long to me.
Plus, that there is a file within the pdx, though I don't know if that's normal for a Pulp game.

I mean, i don't know anything about this, but these are the two things I would try changing.

The .json file is by default bundled into the PDX and we left it in here so that it can still be looked at if anyone wants to. The .json file existing in the .zip shouldn't be an issue in itself.

I did shorten the author string length immediately and re-upload once Tim mentioned the possibility.