Help with "pdxinfo file not found" Error


Hi, my game is not running in the simulator at all, instead returning the "pdxinfo file not found" error. It's been working fine so far, so I assume it's a syntax error in my code that I can't find. I've attached the project file below if someone wouldn't mind looking through my code. Thank you!!!

Molar Mayhem (1.8 MB)

When I try to compile I get error: Unsupported WAV encoding type: 2, which isn't very helpful. It took me like 10 minutes of googling to find that format 2 is the Microsoft ADPCM format, which is different from the IMA ADPCM format that we support. They're not really compatible so we went with IMA only because it's much more common.

I'll file an issue to have the compiler explain the type 2 error better. There's also another issue we have open to delete the output pdx if compilation failed--that would have saved some confusion here, too. In the mean time, if you re-encode the files to plain WAV or IMA ADPCM (we recommend the adpcm-xq tool) it compiles. Here's your audio encoded with adpcm-xq -5: (2.3 MB)

After fixing that I get

toothSpawner.lua:53: attempt to index a nil value (global 'ToothSpawner')
stack traceback:
	toothSpawner.lua:53: in main chunk
stack traceback:
	[C]: in function 'import'
	main.lua:13: in main chunk

when I run the game. It's trying to create the ToothSpawner.update function but ToothSpawner doesn't exist. I don't see any other references to ToothSpawner in the code, either. :person_shrugging:

this fixed it, thanks so much! Oddly, when I use sound:play() it says "need check nil" for sound and Undefined field "play" but when running the game it works fine :person_shrugging: