How to add games to Launcher in simulation

Is it possible, and if so how, to add games to the simulation? I've tried to put my .pdx folder in Disk/Games, Disk/Data, and Disk/System, and nothing adds it to the launcher.


you should be able to add games by dropping the pdx folder into Disk/Games and resetting the simulation. If it doesn't show there might be an issue with the folder structure or the pdex file itself. You have to register the simulator to run games from inside the sim (take a look here: Registering Playdate using Wifi)

Putting the pdx in Disk/Games should be enough, registering the simulator shouldn't be necessary. If it's not showing up after a reload.. I'm not sure how the launcher is even loading? :thinking:

What platform are you running on?

I am using Ubuntu Linux. I tried to put the game into the Disk/Games folder again. Here is some potentially good information.

You can see here that the game doesn't show up in the Launcher, even though its .pdx folder is in Disk/Games.

On macOS I use this little script to set up a shortcut in PlaydateSDK/Disk/Games to my game build file located elsewhere:

#!/usr/bin/env bash
: ${1?"Usage: $0 folder game.pdx"}
: ${2?"Usage: $0 folder game.pdx"}

ln -s "/Volumes/External/Users/matt/Projects/Playdate/$FOLDER/$GAME" "/Applications/PlaydateSDK/Disk/Games/$GAME"
  • -s creates a symbolic link
  • It's important that both paths are absolute (and not relative like ~/Projects/Playdate/...)
  • I keep the script at /Applications/PlaydateSDK/Disk/Games/
  • folder is your project folder name
  • game.pdx is your .pdx name

Usage: ./ folder game.pdx

If this doesn't work on Linux, there may be a difference with the Simulator on that platform?


I have found the problem. On Linux, the filesystem is case sensitive, and your .pdx folder found in Disk/Games should be lowercase. For example, Crafty.pdx didn't work, but crafty.pdx did!

this still did not solve it for me. my game was fully lower cased, but not showing up. What finally worked was adding a second game to the Games folder. There is another bug about the playdate only loading some files, particularly on linux. I think that's what I was running into. I just copied my pdx to a new "aaa.pdx" file and then my real pdx showed up in the launcher.

The fake aaa.pdx game does not show up, and when I list games in settings, it gives a bunch of console warnings about files and folders in aaa.pdx not being accessible. But otherwise, the card for my real game shows up in the list and it runs fine.