Cannot Register Simulator (404 url)

I see... Well thank you for letting me know :slight_smile:

Thanks everyone for reporting! We're taking a look at it right now and will reply back here when we have an update!

1 Like

Hey folks, to get registered you first have to connect the Playdate OS to wifi. Yeah, it's a bit odd and not obvious, we apologize. We're adding a dialog if it's not set up before attempting to register. Secondly, on Windows/Linux there is a bug where the OS won't remember your wifi settings. We're getting that cleared up as well. Lastly, you only need an access token if you want to use the leaderboard APIs. You should be able to get started without registering your simulator.

Hope this helps a bit!



How do you connect the simulator to wifi? How to connect to internet on Simulatior - this thread seems to suggest you cannot

Thar’s an error on my part.

In the Settings app, select one of the test wifi networks. The pw is the same as the name (it's a dummy connection to your computers networking stack). This step is required for registering the Sim and using the leaderboard APIs.


So apparently my problems playing games were arising because I was trying to open .pdx directories from my D: drive. If I open them from my C: drive they work fine. Perhaps the PlaydateSDK needs to be installed on the C: drive in order to register?

That's strange because I'm able to open things fine on my E: drive. I don't think it needs to be installed on the C drive to register the token or games. You should be able to open pdx bundles via CTRL+O anywhere, but when selecting them as a game in the simulator they have to be in the Disk->Games folder. You have to register the sim via wi-fi as mentioned by Will earlier to play games from the sim.

I finally got it working for me. MAKE SURE YOUR SIM IS CONNECTED TO WIFI Before you register. Here's how I did it.

  1. Click "Register Simulator" on the Playdate site.

  2. Click "Register". This should open up a Simulator instance.


  4. Go to the wifi section on the Sim, and connect via the test networks. (test1 is what I use, the passwords are the same as the network name, so the test1 password is test1.)

  5. Once you're connected, then in the Playdate ribbon menu of the window (just below the big border up top), select "Device Serial Number and Token".

  6. The access token area should now be blank. Paste the access token you copied earlier, and THEN, press Register and wait for the process to finish!

NOTE: The sim seems to forget the wifi info, so you will need to go into those settings and enter the password every time you launch it. At least on Windows, and at least for now.

I hope I helped someone. Also, my first post so, hi everyone!


This worked for me on Windows! Thank you!!

Took me a few minutes to understand what #5 "ribbon menu" was. So for anyone else confused by that step - its the main nav bar for the simulator where it says 'file/controls/playdate/view/device/help'. In the 'Playdate' menu item you'll find what @naltohq is referring to.

1 Like

After reading this thread I'm still stuck... after any steps described above attempting to register I still get told I'm not connected to wifi and need to connect before registering.

(all I'm really trying to do is get my card image etc to show up on the simulator, which I can't do for any game, including FlappyBird, but reading the threads for that suggested registering the simulator first, so that's two rabbit holes for today XD - edit: added link: Help using pdxinfo and card.png - #7 by Tengu )

Here's one scenario I've tried, just from going back to the documentation and trying to follow along... what I wind up with is a doom-loop of open simulators, none of which can be registered (screenshots taken from top-to-bottom):

Is there a definitive way to actually register the simulator on Windows? (hopefully one that 'sticks', but I'd settle for just one that lasts long enough to try seeing my or any app's card image for now)

Well, I finally got it to register (some combination of Nick and robbie's posts above), but not quite sure of the steps I used:

Still can't see any card images, though.

Edit: the card images aren't on the 'Games' menu (strangely enough), they're on the main screen... you just have to know to 'scroll up' ('Up' on the DPad) to see them (assuming you've loaded any games into PlaydateSDK/Disk/Games).

This is ridiculous. Am stuck here and giving up!
Edit: It worked. Really unclear though. test1 says connected with no password, and how would you know that the password was 'test1' if you hadn't come here!

Can I ask why you are attempting to register the Simulator? It’s not required, and it won’t unlock any new features :slightly_smiling_face: It’s really a minor feature for Season One developers only.

Because the simulator won't work without you registering it

That’s not correct. If you’re having trouble with the Simulator, registering it won’t fix it. What issue are you running into?

Clicking on options like Games, etc, forced you to register. Registering failed as there wasn’t a WiFi connection, even when there was. Fixed on this page eventually helped after much trial and error. I’m sorry you don’t see it that way, but I was seeing something different

The Games section of Settings isn’t particularly useful in the Simulator—it’s used on Playdate to fetch games from the server. It’s not something you’d need to do in the Simulator at all.

I’m sorry you’re having trouble, but I think there’s an underlying miscommunication we need to address. What are you trying to do in the Games section of Settings? If I know what your end goal is, I can help.

1 Like

TBH it was exploring the sim. There isn’t anything saying “This isn’t needed” or “Don’t touch that”

I can use VS Code to run samples now, which is all I really need, I suppose, but if something is on the Sim I’ll poke it, of course

1 Like

It seems as though this has been completely fixed. Downloaded V1.10 and it was already connected to the Internet.