I can't open my pdx file on the simulator (Windows 10, SDK 1.13.2, C api)

Hello everyone, I'm following this tutorial and I'm having problems trying to run the pdx file on the simulator. This happens using the command:

  • PlaydateSimulator .\c_template.pdx\

Does anyone know what could be the issue here? Thanks in advance!

The tutorial you're following is pretty old, I'd suggest following the Inside Playdate with C (Windows section) to set up your project. A lot of this is now done automatically or not needed. Second, it's hard to say what the problem is, but first check to make sure there is a .dll file inside of your pdx folder and it's not zero bytes. Lastly, you don't have to prefix your .pdx path with a .\. The command should be PlaydateSimulator.exe c_template.pdx. Hope this helps get you up and running!

1 Like

There was no .dll file on the generated pdx folder, so I don't know what the problem was. I tried following the Inside Playdate with C tutorial and it worked perfectly, thank you so much!