Playdate code completion in Nova IDE not really working


Got my playdate this weekend and I'm messing around with experiments in the Nova IDE. I'm finding the code completion to be atrocious. I can't tell if it's kinda working or not, since I have no real point of reference.

This is my first time working with Lua. I've worked with javascript in the past and the code completion there was always super dicey, so I'm just wondering if this is expected behavior with Lua, or if it should be working as well as I expect it should be. I'm coming from C# where code completion and other IDE features like Find References, Jump to Definition, and Refactor typically work flawlessly

Am I just misconfigured somehow or should I just focus on memorizing the documentation? I have installed the playdate extension, and I've tried both Nova 11 and 10.6...

Can't tell exactly what is or isn't happening for you, but I've found it meets my needs well in Nova 10.6.

it seems like code completion just throws everything at the wall to see what sticks, instead of picking the actually correct options.

for example, I have this Trail class that has a single method, 'tick'. code completion pulls up all this unrelated stuff (nova 10.6) -

it's basically the same thing if I try any of the playdate stuff, e.g.

1 Like

You're right, it's doing that for me too. I'm not sure whether it always did or not... I tend to type enough of the term that the autocomplete is one of the top few, so I haven't been noticing what happens if you just browse.

(Which of course I had to do when I was new at this—but I probably browsed the docs instead of the autocomplete.)

So I don't know if that's normal/intended.

sure, thanks for confirming at least!

I'll probably get used to it eventually, but it has definitely been a learning hurdle.

1 Like

I'd reach out to Nova Support through the Help menu > Report a problem...