Vscode failing to get SDK path on Mac


I'm trying to get vscode set up with the SDK on Mac, but I keep getting the error "vscode-playdate: Failed to get SDK path". I have the recommended extensions installed (Lua, Lua Plus, Playdate) and I've set playdate_sdk_path in terminal and settings.json. Is there something I'm missing? This is the tutorial I was following: Setting up your Mac to create a Playdate app | RexBlog

Nevermind, I fixed the problem myself. Just needed to change some settings in vscode.

Just to update this as I was having the same issue and was about to ask @RexH where those settings were but realised I could take the initiative and find them myself. In case anyone else stumbles on this go to Code/Preferences/Settings and do a search for 'playdate and it'll give you three settings one of which is, sure enough, 'Playdate: SDK path' where you can update it there.

At least I think that's the one as I've yet to be able to compile!

Also I found this was helpful from the point of view of a Mac.